Chrome browser issues with Launcher

Aug 30, 2013

Since I am now forcing my content to open up without browser controls by launching the player into a new window (as a tab or pop-up), I've noticed something unique happen when using Google Chrome with published content (this issue does not occur when previewing it). It seems that when viewing the launcher page in Chrome, the Storyline course will get immediately blocked right after it since it attempts to launch automatically as a new pop-up window. This is a normal browser reaction that we see in Firefox and IE. In fact, to reduce confusion for the end-user, I have created a custom launcher page for my actual courses that provides a unique launch button as well as directions that request the user to allow pop-ups when accessing the content (not used with this sample).  However, what's really odd with Chrome is that before I can click on the launch button, somehow the audio has already started to play from slide 1 without any visible new tabs or windows popping up (all you see is the original launcher screen). I've tested this out on different courses using our organization's website as well as my own personal site with the same results. You can test this on a sample project (which is just text on two blank slides) here.  I have also attached the sample story file so you can study its player settings. You'll also notice that if you attempt to click on the launch button after seeing the launcher screen in Chrome and hearing the audio, you'll then end up with two audio tracks playing simultaneously but only one course window. It's really strange. Does anyone have any explanations or workaround that won't require me to tell end-users to avoid Chrome (not realistic) or stop using a launcher page? 

13 Replies
Ashley Terwilliger-Pollard

Hi Pete,

Chrome is generally my preferred browser, so I tried this out. Your test link to the sample project played exactly as you described with the launch button and audio playing even before I hit the button, and then once I hit the button overlapping audio. As for the test.story file you included, I checked all the player settings and didn't see anything out of the ordinary, so I published that one to my Articulate Online account ( and it played (without the launch button) and without repeating audio. So I'm unable to recreate what you're describing with the file you attached. 

If you'd like to submit it as a Support case our team is happy to take a deeper look at what's happening, and it may be best to share the actual file you're working on with them (it's shared privately). 

Pete K

Can someone else confirm if this is an issue when opening this link in Chrome (now sharing via Google Drive)? The strange thing is that it is a test story file with only 2 slides with just text and audio (that's it). The Articulate engineer working on the issue insists that he cannot replicate the issue but I have replicated the problem on different computers on two different networks (home and at work). The other browsers don't experience the premature audio issue with the course from the launch screen.  However, upon clicking on the link, Chrome starts to play the audio file without the course even launching. To test this, click on the link and wait about 5 seconds. You'll hear salsa music and then when you finally use the launch button, the audio file continues to play on top of the regular course audio simultaneously. Am I losing it or is this really an issue?

I would love someone to test this out with a separate course (even just one slide). Simply add an audio file to the first slide, publish the course, and post it online. Once you do, open the link in Chrome, which will take you to the launcher screen (default browser settings will block new window). Then wait 5 seconds or so and the audio begins to play on its own without the course actually launching (or you clicking on launch button). I'll bet money that this is a bug. Though the real question is whose bug is it to fix (Google or Articulate)?

Pete K

Thank you for confirming the link issue. Now for the challenge! Would someone be brave enough to try and replicate the issue by building a two slide course like I did. Simply add an audio file to the first slide, and enable launch page in player settings.

Afterwards, publish the course, and post it online. Once you do, open the link in Chrome, which will take you to the launcher screen (default browser settings will block new window). Then wait 5 seconds or so and the audio begins to play on its own without the course actually launching (or you clicking on launch button). Did it respond the same way it did for me?

Pano K.

You can replicate the issue above by using the player settings shown in the attached screenshot. The problem is that the pop-blocker in Chrome is not working as expected. If it were turned off, the audio issue with the SL launcher screen goes away, but doing so leaves the end-user vulnerable. This simply is not a normal behavior for any pop-up window or pop-up blocker.

Ashley Terwilliger-Pollard

Thanks Pete - I looked into the case, and it seems that Jonathon is doing some additional testing and has shared it with our QA team to determine if there is a fix for Storyline to deal with the Chrome issue that is being presented. 

What's weird to me though, is this case is listed as being created by a different name? Alternate identity?  

Pete K

I have found a temporary workaround to the full screen launcher issue. The problem has to do with how Chrome and Opera render a page that is still loading. Since the slides in my course automatically advance to the slide that contains the audio, the audio is automatically played in these browsers even when the course itself as a whole is blocked. However, it seems that if I force the user to click Next in the beginning of the course on a slide where there is no audio, then Chrome and Opera will not automatically play the initial audio content on the launcher page when the course is initially blocked. However, I'll have to go back through all my courses to add this step which will take time.

While a customer support engineer has confirmed with me that this issue is now being reviewed by their Quality Assurance Team, he wasn't able to provide a time frame as to when this will be addressed.

So for now, if you're using a launcher page with audio, you have several workaround options:

1) Avoid using audio that automatically plays when the course begins (whether in the slide or a different object that is initiated).

2) If audio is necessary in the beginning, force the user to manually advance to the slide that contains the audio (use Next or another trigger).

3) Ask end-users to change browser settings to allow pop-ups (not simple and may raise concerns).

4) Inform end-users that Chrome and Opera are not recommended browsers and hope they comply (good luck with hard core Chrome users).

5) Disable use of a launcher page under Player Properties - Other (which means course will not launch in full screen unless manually activated by user through browser).

For me, #1, #2, and #5 seem to be the more realistic options.

This discussion is closed. You can start a new discussion or contact Articulate Support.