Chrome issues

Hi All,

I’m having issues with playback in chrome. I have a project ongoing at the moment where the course is hanging and not displaying properly (both web and SCO). But the same link works fine in IE and Firefox.

On investigation, my side and the client side, it has been narrowed down to the js files in the “html5/data/js” folders being blocked / not accepted (406). It looks like with strict MIME type checking in Chrome all the js files in this folder, which are (‘text/html’), are not executing.

There is nothing I can really think of from an authoring point of view that could resolve this. It has also been suggested to publish using the ‘modern player’ but that seemingly get further but really it just gets past the spinner and the same issue occurs.

Any ideas?

Just to note - I’ve not applied the latest update (July 24th) but there isn’t anything listed that looks like it would address this issue. 

9 Replies
Leslie McKerchie

Hi Russ,

The specific issue that was shared here was exclusive to Google Chrome when publishing to web and hosting on a web server.

  • Is your client experiencing an error?
  • What version of Storyline are you using?
  • How are you publishing/sharing the content?

If you have a .story file you'd like us to take a look at, please feel free to share.

Russ Sawchuk

Hi Leslie,

Yes, the client is experiencing the same issues using Safari as with Chrome - presentation stalls after the first slide. Next button nor menu does not work. Interestingly enough, the presentation plays fine on an iPad when using the Articulate Player, but not without it on an iPhone or iPod.

I am using SL 3, Update 4 or the latest version. In fact I had to republish all of the SL presentations because the new SL update came out just after I had sent them the course videos to upload.

I publish to the web using HTML5 with Flash fallback with AMP. The site was built using ColdFusion so some of the file endings had to be changed. However, SL worked fine for the last year or so without any issues. Even the latest SL versions worked fine until a few weeks ago.

I checked SL programs I have developed and installed on 3 other clients' servers. Everything seems to working fine on the other installation. So the issue seems to be with this one server.

I have sent the client's hosting techs a new app.min.js file as suggested in the above support article. Hopefully that fixes the problem. If not, I will be back here for some more help.

Thanks,

Russ

 

Russ Sawchuk

Leslie,

Here is an update. Changing the "app.min.js" file did NOT fix the problem. Fortunately, the hosting company was willing to change the website config to "application/javascript".

That fixed the SL issues on BOTH the Chrome and Safari browsers. Hopefully this will help anyone else who has the same problem.

Thanks for the support article. It saved me much grief!

Russ