Chrome, Storyline 2, HTML5 and Amazon S3

Hi guys.

My courses are stored on Amazon S3 and they work fine if exported from my trial version of SL3 - but I've noticed when exported from SL3, Chrome uses the flash version of the course. When exported from SL2, Chrome defaults to the HTML5 version - which doesn't work!

On both programs, I export for LMS - Scorm 1.2 using the default settings.

When I load the story.html file of courses from SL2, sometimes the link tells me it's using the story_html5.html which start fine but when they get to the first scene change the screen goes blank and I can still click buttons on the screen (even though they're invisible). The whole course is just odd from thereon out though - transparency doesn't show up on images, fonts change type and size, animations don't work properly... it's just a horror show.

I've no idea what is causing this, but I'd appreciate any help. It seems that the HTML5 versions of my courses from SL2 just do not work at all in Chrome. Flash versions seem to be working fine. HTML5 courses from SL3 work fine, so I don't know if it's a problem with SL2, Amazon S3 or the course itself. It's temperamental too - some courses will work on my Chrome on a Windows computer, but not on a colleagues Chrome on a Mac.

It's worth noting too that if I export a zip of any course on SL2 and upload it to Tempshare, they always work flawlessly.

4 Replies
Walt Hamilton

You said:  It's worth noting too that if I export a zip of any course on SL2 and upload it to Tempshare, they always work flawlessly.

and that's your answer. If you publish for LMS, expect it not to work well when accessed from any location except an LMS. Publishing for LMS and attempting to access it from a local computer, network, or internet almost always gets the results you describe. If you want to access the course from S3, you need to choose to publish for the web.