Closed Captions won't change

Hello. In the attached file, I have Arabic closed captions on the first slide and Chinese CC on the second slide. However, only the Chinese CC displays for both slides. It's the same video on both slides, but I thought I could change the CC since it's a different object/slide. Any idea why this isn't working? Thanks!

13 Replies
Bob O'Donnell

Its showing Chinese because both your videos have the SAME .srt file "Chinese" listed in the Media Library. Instead of reading the CCing you have inserted, the .srt file is overriding the captions you input in Arabic. My guess is it has to do with the Media library - its automatically associating your "single video" with the same .srt captions file. Frankly I wish you could turn that feature off, but that is just me. When you added your Chinese slide in, the CCing was associated with the video anywhere it appears.

First off - make sure you have a good copy of your Arabic closed captions. Your best bet is to save a second copy of the video and label it something different like Beatrice-Onboarding_Arabic.mp4 and then insert that into the Arabic slide. Then the media library will be happy that you have 2 different files and treat the CCing separately. Once the new video is in, you can import the Arabic CC and it should play as expected.

One last note - The beginning of both CC files should have an extra caption block in the very beginning indicating that there is "Music Playing". No text is necessary, just music symbols, like this: [♪♪]

Bob O'Donnell

Wendy, It would be nice if the system could recognize that the video is on a completely different slide. Then you could use whatever captions you want. Before the media library was added, you could probably actually use different CC text. We've had similar, but minor issues with graphics in the media library.

Stephen Calhoun

The media library actually shows two separate .srt files being associated with the same video (see attachment). When I renamed the slide to something different, it still comes in with the wrong .srt file attahed. Very strange. Also I don't really want it to view the video as 2 separate files as that doubles the output size as well.

Thanks for the response. It's just odd behavior. Maybe I'll raise the case with Articulate.

Bob O'Donnell

Stephen, I think you basically have 2 options to keep the course size smaller. One would be to post the video(s) externally and link to them, the other would be to take your existing video and run it through a compression program to knock the file size down which is a fairly easy solution. More than likely there is a lot of fat in your existing video. You may be surprised at the results.

Phil - Are putting in an "Official Request"? It would be nice. ; )

Stephen Calhoun

Response from Articulate support: 

"I am sorry to hear that you are having problems with closed captions in your course.

This is an issue that we have logged as a possible bug in Storyline.  This will happen if you use the same video in multiple slides containing closed captions.

To resolve this, you will need to change the title of the second video through its File Properties."

So basically what Bob was saying where I need to create videos that Storyline identifies as distinct. Oh well. Maybe in the next update!

Ren Gomez
Hi Everyone,
 
Great news! We just released another update for Articulate 360 and included a few important fixes for Storyline 360 that you'll see in the release notes.
The issue you were running into where Incorrect Closed Captions of the video being shown on the slides for SL360 update 35 has been fixed.
 
Just launch the Articulate 360 desktop app on your computer and click the Update button for Storyline 360. Details here.