14 Replies
Ashley Terwilliger

Hi Ed and Robert,

Sorry to hear you've run into some tracking issues recently! I'd love to help get to the bottom of this and will need a bit more info. 

  • What version of Storyline are you using? Are you also on the latest update?  You can check by going to the "Help" Tab -> "About Articulate Storyline"

    Storyline 3, build 3.5.16548.0 and Storyline 360, build 3.23.17480.0 would be the most recent. 

  • What browser do you view the courses in? Do you know if you're viewing Flash or HTML5?
  • What LMS are you hosting in? 
  • Can you share more details about what is not being tracked? Is this happening for all learners? 

Let us know the above, and we'll figure out where things went off the rails! 

Robert Brock

Hi Ashley,

  • We are running SL360 3.23.17480.0
  • IE 11
  • Cornerstone on Demand
  • We have seen learners not receiving "Completion" credit for single modules that are part of a lesson. Upon second try, completion was recorded. Also, we have had a few learners report a "resume" loop after exiting a lesson after completing a test. For example, subject would take the test and pass. Then, they would exit to the LMS menu and try to continue to the next lesson. The prompt to resume would come up and take them to the same test again. We figured out that clearing the browser cache would allow the user to advance in most cases, not all. The issues that have been popping up in the last few days have been inconsistent at best.

Thanks

Ashley Terwilliger

Hi Robert, 

Thanks for those details - and glad you're on the latest update of Storyline 360!

Are you only able to use IE11? I haven't heard of any browser updates that would cause similar, but it'd be good to know if the same thing occurs if one of those learners access the course in Chrome, Firefox or Edge. That may narrow down the issue further!

Also, for the completion piece, do each of those modules have their own completion/tracking within the lesson or is there a master tracking for the whole lesson? Storyline can only send one tracking/completion element per file, so if you've set up more than that in the LMS, I'd suggest reaching out to the Cornerstone admin for help!  

E W

Hmmm, interesting to hear we're not the only ones experiencing this.  It's very strange, as this is affecting courses seemingly at random.  Some have been on the LMS a long time without issue and others are recently published, so likely published under different versions of Storyline.

To answer your questions:

  • We're using 360 v 3.22.17236.0, although some courses might have been produced under previous versions.
  • Courses are viewed in various browsers by our users.  I haven't yet determined if there's a common theme behind user completion based on browser though.  Users are either on Google Chrome, IE11 or Firefox typically.  I know we've had issues with users on both IE11 and Chrome.  
  • Moodle (self-hosted by us)
  • We are monitoring "Course Complete" via the set course to complete trigger within 360 on the final slide.  It is happening intermittently it seems (most users are fine I think)
E W

We're still getting a strange spike in users receiving issues on courses - weirdly, this is affecting all courses, irrespective of whether they've been published ages ago or recently, so I'm not sure version number will be relevant.

Please can someone come back to me ASAP as this is a really big problem for us at the moment.

Katie Riggio

Appreciate you working through this oddity with us, Robert and Ed! I can appreciate that it's frustrating when only a few learners are running into this intermittent completion issue.

I hope you both don't mind, but I've opened two separate support cases with our Support Engineers, as they're rock-stars at spotting trends and the root of such behavior! Look out for an email from the team shortly, and I'll follow both cases along so I can share any needed updates here!

E W

Hi Katie

I appreciate you raising this with Support, but unfortunately they've sent me the token response about "if tested in SCORM cloud then it's likely an LMS issue".  

I don't think that's the case here.  The LMS hasn't changed nor has it had any updates recently to cause the issue - it's the same version etc and all courses have performed as expected until recently.  In addition, Robert has experienced the same recent issues on a completely different LMS?

Ashley Terwilliger

Hi Ed,

I saw in your case you also mentioned browser updates or updates to Storyline. Do you know if there were any recent browser updates on your end?

As far as updates to Storyline, you would need to have installed that update and republished the content for any of those changes to take effect in your course. 

Although you and Robert have run into similar issues, I wouldn't yet call this a trend as we're not hearing it from other individuals in cases or forum discussions. I'll reach out to Rona on your case (and Lea on Roberts) so that we can circle up and make sure everyone is on the same page.

E W

Hi Ashley, sorry for the slow reply.  I have been trying to narrow down the issues... without success.

Re browser updates - its impossible to say.  We have clients all around the world, all using different browsers and there doesn't appear to be any consistency to it.  What I would say, is that it is becoming more frequent and also strangely affecting courses that were previously fine - hence I wonder if it is something to do with browsers?

Would HTML5 only output have any affect on improving the reliability of completion status passing to the LMS?  Or is there no way that could be linked (we currently publish to HTML5 with Flash back up but on occassion have user issues as browsers try to revert to Flash rendering certain elements useless) - so wonder if it could be in anyway linked to Flash somehow preventing completion status passing?