Conditions on triggers not triggering changes

I'm having some issues getting a trigger with conditions to correctly change the state of an object.

I have these same conditions individually changing the state of other objects on the page. Even when all 3 of those states are changed based on the True setting, the arrow object below won't change state to normal.

I tried it in several spots in the trigger order.

Any thoughts about what I'm missing here would be very helpful.

Thanks

8 Replies
Sara Reller

Tim, thank you. I thought about that but the timeline starts trigger works as the trigger for the other items which also set when the timeline starts.

I attached the file and would appreciate any help. 

The idea is that they don't get the link to take the test (which will be outside of Storyline) until they are done with each of the modules. 

Sara Reller

I am waiting to hear back from the people who have opinions that count on what color/visited/not visited etc should look like so they are just enough so I can tell for now. But yes I know those need to be more distinct. 

Fresh set of eyes was just what I needed I was so focused on getting the trigger to work that way that I wasn't even able to look for another work around to get past it. Sometimes "why not just..." is exactly what is needed. 

Thanks!

Brian Allen

Sara Reller said:

I am waiting to hear back from the people who have opinions that count on what color/visited/not visited etc should look like so they are just enough so I can tell for now. But yes I know those need to be more distinct.  

Thanks!


You could do a color change, or more often I see folks do something like add a checkmark or something if the section has already been completed, which is a very good visual...