Copy and pasting objects stops working

Hello Articulate community,

I'm trying to diagnose an issue - since the latest update to Storyline has anyone experienced intermittent issues with copy/pasting objects between slides? The issue is that the copy/paste stops working randomly - it just doesn't seem to copy. This is with any combination of Ctrl+C/V, CMD+C/V or right-click copy/paste, or Copy/Paste on the menu. When I first open a project it works fine. Then, after about 20 minutes or so of working it stops randomly. I can still copy/paste text just fine, just not objects (simple rectangles for example). This happens in multiple, unrelated projects (NOT the same template, not even the same type of project, completely different days).

I can copy/paste objects in other programs (e.g. PowerPoint and Word). It's just in Storyline 360 (latest update installed).

I can close/reopen the project (again, happens on any project, not a specific one) and copy/paste works again for a bit before stopping again.

I've tried increasing the RAM on the VM (see below); I've tried reinstalling Parallels Tools again; I've restarted the entire computer (Windows then Mac);

My setup - Windows 10 running in Parallels on a iMac with 8 gb of Ram dedicated to VM (24 gb Ram total on the Mac). All the latest Windows updates installed and Parallels version 14. Over 700 gb of hard drive space available (Mac 1 tb fusion drive).

Has anyone run into anything similar or offer any additional ideas? I'm stumped and this is driving me nutty. 4 days in to trying to diagnose this.

 

70 Replies
Phil Mayor

I had this on a beta version and found it was related to my system resources, although I was on my laptop and only had 8gb of total RAM(never had problem on my desktop but I do have 64gb of RAM).

What else are you running on your Mac?

I found it happened if I moved fast and didn't give the the program time to copy the object or the slide.

It may not be related but you may want to view activity monitor and see if there are any low resource issues. I would also say after I switched to a 32gb laptop it never happened again.

I feel your frustration and would expect 24gb of RAM to work fine, may need you to raise a support case.

Leah Hemeon

Thank you for the suggestions Phil. I too ran into something similar in an original beta and it went away when I upped my RAM on the VM. To no avail this time though. On the Mac side I only have Chrome (5 tabs), text editor and messages open. Activity Monitor shows lots of CPU and RAM available (around 30% used on either at any given time). Windows side I have one SL file, two Word docs and a PowerPoint open. About 40% of system resources in use. I'm stumped on this one.

Martin Dean

Hi - I am having the same problem, on a very new iMac with 32Gb of RAM.  This has been happening for a number of weeks now.  

I am also experiencing the 'red cross of death' on an almost daily basis... where SL decides it is not well enough to continue and puts a blank white rectangle over part of the interface with a red border and diagonals.

It then asks what I was doing when it happened.  I started by trying to be accurate about this but it has happened so many times, I am afraid my responses have become increasingly sarcastic!

On  a serious note, I am often concerned that this software is not fit for purpose; which is very worrying as I have little choice than to continue to use it.

Martin Dean

Some more info on this:

I have a Mac Utility called PASTE which retains my clipboard data (from Windows and Mac).  It is showing that I am copying into the clipboard.  On many occasions, I am unable to paste into SL.

I have found that if I select the destination - for example the slide display area where I want to paste, that pasting works more often than if I select the thumbnail of the destination slide (bad habit I have).

I also can select and copy/paste whole slides without this issue.

I think this is a bug

Ashley Terwilliger-Pollard

Hi Martin,

Our team is happy to work through it with you, one on one. I'd also want to make sure that you're following these other guidelines and best practices for working on a Mac with Storyline. It could be the shared profile between Windows and your Mac is causing some trouble! 

Let me know if you've reached out to the team, and I can follow along in your case! 

Lloyd Hill

I am also now having issues with copy paste on slides after installing the latest upgrade of Storyline 360. I can copy and paste slides from the story view but can't copy and paste assets on any given slide. I have another developer that hasn't yet upgraded to the latest release and he is able to copy and paste at slide level using my story file. Please fix asap as it is a show stopper.

Martin Dean

I have re-visited the 'best practices' article and confirm that although I do not follow all the guidelines, I never have and my Mac/PC environments have been fine.  It would not suit my workflow at all if I were to disable the shared aspects of working with Parallels.

I did increase my RAM allocation in the Parallels configuration and that seems to have lessened the frequency of the copy/paste problem.  However, it has not fixed the problem.

I agree with Lloyd - this is a showstopper.

Leah Hemeon

Thank you Martin - I did the reinstall of Parallels Tools last week and it worked briefly but again after about 45 minutes of working in Storyline it stopped copy/pasting again :( I'm sort of glad that others are now experiencing this and reporting it. I'm working with Articulate Support on the issue as well and I'm hoping we can find the issue. For now they've downgraded my install to the one before the May 28th release and that has seemed to temporarily fix the issue.

Before downgrading I had found all kinds of random half-fixes - sometimes opening a Word doc and copying and pasting random text in the Word doc would temporarily fix the issue in Storyline (random, I know), another time I used PowerPoint, inserted an object in PowerPoint and randomly copy/pasted in PowerPoint and then went back to Storyline and it worked to copy/paste SL objects again for a bit. However, then all of those workarounds stopped working too. Unfortunately it was very, very difficult for me to catch the behaviour on video since starting a Peek or SnagIt recording also seemed to briefly clear the issue - just long enough for me to not be able to capture the video :( I managed finally to catch it once and sent it to Support because, of course, when I was screensharing with support it wouldn't do it.

If anyone out there having this issue can capture the issue on video (CTRL+C/V, CMD+C/V, Copy/paste on the Home menu, or right-click copy/paste), please do so and also start a support ticket to get these issues officially reported.

Leah Hemeon

Sounds like the project I'm working on! Last week I was moving a course into a new template and although I wasn't copy/pasting between SL files, I was rebuilding slides from scratch but using some pre-built slides in my new template which I'd need to copy/paste elements from. 60+ slide project and lots of objects to move around. Grrr.

Leah Hemeon

I agree Lloyd. I’ve been working in Storyline all day today on a project and haven’t had any issues with copy/paste since downgrading to the May 7th release. I have a call with a senior engineer with Articulate Support tomorrow and I hope they’re going to say the same. For the time being though I’m hanging tight on the older version until this gets sorted out. My productivity was crazy low last week mostly due to being slowed down by this one issue and all the troubleshooting and work arounds I had to do.

Gerry Wasiluk

Just for giggles, when cut and paste stops working, in Windows, go to Task Manager and see how much memory SL360 is using.

I've found that when memory use goes over 1000 MB strange things often happen with SL360 on my main workstation.  I experienced cut and paste stop working for me last week a couple of times, and, when I checked in Task Manager, memory use was over 1000 MB.  (Don't know if 1000 MB is a constant for everyone or a number that depends on the system.)

Not sure if that's what's happening here or not but it'd be interesting to see if this was a factor for others.  Might help Articulate address the issue.

There were memory issues about a year ago and things got better as Articulate worked hard to address things, but, it seems, things might possibly have regressed. :(

In the past, whenever I noticed SL360 go over 1000 MB, I'd save everything, close SL360, and reboot the PC.  Inconvenient but I didn't want to lose work or have something else untoward happen to my project.

Gerry Wasiluk

Interesting.  Many weird things happening for me "seem" to sometimes happen after doing cut and paste.  If I do a lot of it, memory usage spikes very quickly.

I also have 64gb of RAM on my main workstation and I run Windows 10 Pro natively.

This is way beyond my pay grade but would a 64-bit version of SL possibly help?

Martin Dean

I have now 'down-dated' my SL360 and the problem seems to have gone away (thank you Leah!)

In case anyone else is having the issue, I suggest installing version 3.27.18822.0 (select 'other versions' from the dropdown list on the updates button in A360).

I did test the most recent version before deciding to revert to the previous release.  It had the same issue with copy and paste.

Leah Hemeon

Glad to know it worked for someone else too. I've been working behind the scenes with Articulate Support on this. I can't give an "official" update of course but I do know that they were able to replicate it on my machine themselves on update 28 and 29 but it doesn't manifest on update 27 (May 7 release). Fingers crossed they find the issue in the latest updates and are able to fix it permanently - I REALLY want update 29 for the Chrome fuzzy image fixes :(

Leah Hemeon

For those in the community who may be experiencing this too... An update I received via email on my support ticket. If you're experiencing this issue and haven't already submitted a support ticket, please do so as the more we report the issue the more aware of it the developers will be.

"Thanks so much for letting us know about this issue. We’ve logged it as a possible software bug.

As a workaround, you can continue to use Storyline 360 Build 3.27.18822.0 when working on your project. Should you wish to take advantage of the fixes and improvements that were rolled out on the latest builds, you can opt to update to the latest Storyline Build 3.29.19305.0 before publishing your course.

From here, I’ll meet with my team to take a closer look so we can determine the next steps. Sometimes my team catches errors in my logic and we don’t have a bug after all. Of course, if that’s the case, I’ll let you know!

Depending on priority and risk, some bugs can be fixed quickly, while others take longer to resolve. Here's more information on how we identify and tackle bugs:

https://articulate.com/support/article/How-We-Tackle-Bugs

I’ll let you know as soon as we have an update on this issue. Thanks so much again for letting us know about this, and I’m sorry if it’s slowing you down."