Copy and pasting objects stops working

Hello Articulate community,

I'm trying to diagnose an issue - since the latest update to Storyline has anyone experienced intermittent issues with copy/pasting objects between slides? The issue is that the copy/paste stops working randomly - it just doesn't seem to copy. This is with any combination of Ctrl+C/V, CMD+C/V or right-click copy/paste, or Copy/Paste on the menu. When I first open a project it works fine. Then, after about 20 minutes or so of working it stops randomly. I can still copy/paste text just fine, just not objects (simple rectangles for example). This happens in multiple, unrelated projects (NOT the same template, not even the same type of project, completely different days).

I can copy/paste objects in other programs (e.g. PowerPoint and Word). It's just in Storyline 360 (latest update installed).

I can close/reopen the project (again, happens on any project, not a specific one) and copy/paste works again for a bit before stopping again.

I've tried increasing the RAM on the VM (see below); I've tried reinstalling Parallels Tools again; I've restarted the entire computer (Windows then Mac);

My setup - Windows 10 running in Parallels on a iMac with 8 gb of Ram dedicated to VM (24 gb Ram total on the Mac). All the latest Windows updates installed and Parallels version 14. Over 700 gb of hard drive space available (Mac 1 tb fusion drive).

Has anyone run into anything similar or offer any additional ideas? I'm stumped and this is driving me nutty. 4 days in to trying to diagnose this.

 

70 Replies
Mike .

I tried reinstalling Parallels tools and that did not fix the issue. It sounds like maybe you are having more system wide copy paste issues. Copy paste works fine for me across all apps in MacOS and Windows VM EXCEPT for Storyline.

When the next version of Storyline is released Ill retest and post results here again.

Mike .

Yesterday I was forced to update to the latest version of Storyline because of freezing issues when publishing exams. When retaking or reviewing exams on an LMS including SCORM Cloud and Meridian, storyline freezes with a spinning progress wheel. After I upgraded to the latest version of Storyline and republished the exams, the freezing went away. I downgraded and republished and freezing came back just to verify.

So now I have to use the latest version which breaks copy pasting. I hope this issue will be fixed soon!

Patrick Sloan

Hey Mike,  just to follow up with you quickly.  The Copy / Paste issue hasn't arisen for me in several updates.  So it seems like upgrading should not have actually broken the functionality y'know?   Have you tried uninstalling completely and reinstalling from scratch?  Interesting case here.

Mike .

Hi Patrick,

Yes, I have done that. Thanks for asking. Keep in mind that this issues is tied to users who run a virtual machine such as Parallels and then run Storyline on Windows inside that VM.

When I downgrade to the March 2019 build, the issue goes away. Supposedly they fixed the issues in the latest Storyline 360 build, but chose to not yet fix it in Storyline 3. I'm hoping that will come in the next update.

Jessica Shabatura

I am experiencing this in Feb of 2020. No copy/paste functionality on Articulate 360 my Mac Parallels [2013 Mac tower with 32MB RAM]. Did the reinstall of Tools and also the memory bump.

It won't even let me paste a text box so the entire application is simply unusable. Did anyone get a resolution?

Vincent Scoma

Hi Jessica,

Thank you for reaching out and letting us know! I am sorry that you are running into this snag. The issue where copying/pasting objects was resolved in Update 34 for Storyline 360. With that said, I am opening a Support Case on your behalf so we can continue to dive deeper into this! 

Mike .

Restarting the VM stopped being a reliable way of getting copy paste working. I did however try creating 'snapshots' of the VM, one with last years build (copy paste working) and one with current build (copy past not working) and so far that is working very well. Reverting to a snapshot only takes maybe 20 - 30 seconds to switch. Now I can build lessons reliably with the old build, and publish with the new build to ensure compatibility.

Hopefully Articulate is still reading this thread and is working on a real fix for Storyline 3. :-)

 

 

Ren Gomez

Hi Jeff,

I'm sorry to hear this issue is coming up for you! I haven't come across any recent cases where customers have had this resurface.

Are you experiencing this in all files or just the one you're currently working on? If you can connect with our support team to dig into this a little further, they'd be happy to help.

In the meantime, here's how you can revert to a previous version.

Katie Riggio

Hi Ruben,

So sorry to hear this. Storyline 360 Update 34 holds a fix for the issue where the copying and pasting feature stopped working.

I don't see that we have reopened this bug as of yet, but considering you ran into it on a later version, we'll need to investigate!

Our Support team can help in real-time while you copy and paste elements. Let us know if you could screen share with us: