Copying or importing a freeform interaction not working

Hi folks,

I created a freeform Pick One to accommodate multiple data entry fields on a screen.

I followed Jeanette's excellent screencast found here: //www.screenr.com/qiR8.

It works fine, but when I go to copy or import it into another Storyline, it stops working. When it's in the new Storyline, it will not give me a correct answer even though I am entering the correct numbers into the screen. I can't seem to get it working correctly once it is inserted into the new Storyline.

Does anyone know why?

I'll attach the standalone interaction that works so you see what I am doing. It's not rocket science, but I've tried everything to get it working again, to no avail.

Regards,

George

3 Replies
Rebecca Fleisch Cordeiro

Hi George,

I believe it's because when you import into a new story, Storyline duplicates the variables. But, the new Story is still using the old variables.

To illustrate this, I downloaded your story and took a screenshot of the variables. Then I imported the story into a new file and took another screen shot.

George Chruney

Hi Rebecca,

Thank you for this explanation. I hadn't noticed the duplication of the variables, even though I was looking right at them. I had tried so many things that I wasn't aware the act of importing duplicated them. 

So, if I changed them to the new variables, it should work, right?

As a workaround, my colleague suggested that I import all of the screens into the file that I sent the forum, instead of importing the interaction into the new story.

And that solved my problem anyways. I don't know why I didn't think of that in the first place. Geesh,

Thanks again,

George