Course freezes after Storyline 2 upgrade

Hi I have a course developed in SL 1 and it has a mid-term quizzes. If I fail on a quiz and then review the materials, then get back to the quiz slide, I  the Next button doesn't respond.  It is a scored quiz and is set up to have just one attempt, so the quiz slide is brought back for review purposes. The backup version opened in SL1 works just fine (I fail the quiz, review the materials, get back to the quiz slide and am able to click  Next button to move forward.) Thanks in advance for your feedback. 

 

15 Replies
Christie Pollick

H, Tamara - So sorry to hear you are running into issues with your course! Can you please make sure you are working locally as described here! Working from a network drive can lead to file corruption and other odd behaviors. 

You may also find it helpful to import the file into a new file., and sometimes, a simple repair of Storyline will get you back on track.  

Please let us know if you are still having trouble, and if you'd like to share your file, we'll be happy to take a closer look for you! 

Tamara Tarasova

Hi, Christie,

Thanks for the feedback - sorry I got a break from the project and now is getting back to it. I am working from local drive and I also tried exporting the slides into a new project - doesn't work. I am including here a sample of the problem. To tell more, there is similar architecture in several scenes of this project and every time I review the content after incorrect answer, the next button gets stuck.

Another question I am having - I can press Next and Previous buttons in SL1 before the timeline ends but have to wait till the end of the timeline in SL2 - how is that possible? Are there any default settings in SL2 on that? Could that be related to the problem I am having?

Thank you so much!!!

Tamara Tarasova

An update: I just tried importing the slides from SL1 into a blank SL2 file and they have exported as they are in SL1 (I can move next without waiting for the end of the timeline and navigate next after the quiz review. So this issue occurs when I upgraded the project . I am curious, however, how the Next/Previous buttons got disabled during that upgrade. Do you see any triggers in the file I attached. I have been doing a lot of work on disabling those buttons on my previous project and here it happened outside of my will:) Thanks!

Christie Pollick

Hi, Tamara -- Thanks so much for your patience while I tested your file. During my testing, I experienced the same freezing behavior you described, however, I was unable to determine the exact root of the issue, so I created/submitted a Support ticket to have our Engineers take a closer look. You will be contacted via email after they have had an opportunity to review your file, and I will be on the lookout for your case to follow along. 

Tracy Parish

Thank goodness I found this thread.  I have experienced the same thing and was in a complete panic.  I have 8 courses launching on Monday and the NEXT button was not working.  You'd have to click it multiple times before it would advance the slide.  

Same thing with me; courses developed in SL1 and upgraded to SL2.  I did as suggested and created a new blank SL2 course, imported the slides from the upgraded SL2 version of the course.  Ensured I was only working locally.  

First course seems to be okay now.  However this isn't a great fix/workaround when you're on tight deadlines.  Not only do you have to import the entire course, but you also have to re-brand, re-configure player, re-load all the resources, etc.  Really hoping the PD Team can find a fix.  

Two other issues noticed with the Upgraded SL2 Course Version

  1. was that I kept getting an error message when trying to preview.  (reported through the popup window)
  2. some text boxes on slides seemed to look fine in the storyview, but when you opened the slide the text box no longer had the word-wrapping and instead the text now was running off the screen. 
Christie Pollick

UPDATES: I thought I would stop in to share the input offered by our Support Staff pertaining to Tamara's case above:

"Upon checking, it looks like the trigger on the attached screenshot was not properly configured. Please set the specific slide for the "Jump to slide" trigger."

And with respects to Tracy's case, here is what our Engineers shared:

"There were slides in your project that were causing the preview error, specifically the Engage slides 1.4 and 1.38. I deleted these slides and I was able to successfully preview your project. I would suggest that you reinsert the Engage interactions into your project then try to preview and publish your course again."

Hope that helps others who may benefit when coming across this thread. :)