Course window focus change: In Storyline3/360 HTML5 LMS version of the course on IE11 only

Hi,

We are facing an issue with Storyline3/360 HTML5 only LMS version of the course on IE11 only. (working fine on Chrome)

Clicking a button (which triggers only jump to next page) on a particular screen changes the focus of the course window and results in hiding the course window behind any other application window (e.g. MS-Word, any other open desktop application etc.). In console we find few warnings "Tried to focus on non-focusable item". (Screenshot of the console is attached.)

Flash version of the course is working fine.

Please let me know if there is any solution to this. Or Do we need to change any settings in IE which will solve this issue.

15 Replies
Ali Goulet

Hey Sagar,

Thanks for letting us know! Have you reached out to CSOD LMS support? Since the issue is limited to that environment, that would be the next best step.

You may also want to try reaching out in this Cornerstone thread. There are lots of Cornerstone users subscribed there, so you may get some helpful feedback from people with first-hand experience.

Keep us posted! 

Ashley Terwilliger

Hi Darin,

I haven't heard of additional reports about this, even for other LMSs. I'm not sure what Sagar was able to determine with Cornerstone, but you may want to reach out to him directly. 

Are you also seeing this in IE11 only? Have you confirmed that SuccessFactors isn't launching the content into a Compatibility mode for IE? Here's how to check: 

Option 1: Change Your Compatibility View Settings

  • Click the gear icon in Internet Explorer (or click the Tools menu if it's visible), then choose Compatibility View settings.
  • If the website where your course is hosted is listed in Compatibility View, select it and click Remove.
  • Also, if you're using an intranet, such as SharePoint, to host your Rise course, temporarily uncheck Display intranet sites in Compatibility View.
  • Click Close, then launch your course again. If the page is still blank, try the following method.

Option 2: Use the Developer Tools to Switch Document Modes

  • Click the gear icon in Internet Explorer (or click the Tools menu if it's visible), then choose Developer Tools. They'll open across the bottom of your browser.
  • On the right side of the developer bar, you should see an icon that looks like a computer monitor and a smartphone with a number beside it. When you hover over the icon, a tooltip will say Document mode (with a number). Click the icon to display a list of Internet Explorer version numbers.
  • Select version 11, then launch your course again.
Leslie McKerchie

Hi Renee and welcome to E-Learning Heroes :)

Sorry that you're running into a similar problem, but thanks for sharing the results of your testing. Is the issue only happening in your LMS or are you able to replicate the behavior in SCORM Cloud?

Were you able to check the compatibility settings that Ashley shared above?

Jill S

My course was hiding in CSOD using the IE browser. By hiding I mean on a Windows box the course would begin and then at a certain point it would disappear and be accessible only behind the IE icon on the taskbar at the bottom of the Windows desktop. Windows 10 BTW.

It worked fine in SCORM Cloud (both browsers) and in CSOD Chrome. The problem occurred after the first slide and also twice later in the course. We changed settings, we cleared caches, I published using various flavors of SCORM, I re-saved MP4 videos in case there was a codec problem, I created the course over from scratch. I suspected the CSOD administrators were doing something wrong and I'm sure they suspected me. Nothing worked.

I think I finally figured it out. I took out all of the "jump to slide when the timeline ends" occurrences. The slides all involved playing an MP4 and then jumping to the next slide when the video finished. For me, it was the company logo video jumping to a "still" title slide. I combined these into one slide and it worked. No more hiding in IE. I hope this helps someone and I hope others can corroborate my findings.