Course won't preview or publish

Hello!

Anyone come across this before? Working on a course, clicked preview on a slide and all I saw was a black player with no content! I tried copying all the slides across to a new course and the same thing happened. When I try to preview the entire project it freezes at slide 9 of 9 (see screenshot). When I try and publish the course it 'rushes' through the final few slides and doesn't create all of the files you'd expect in the output folder.

Whilst it's only 9 slides I'd rather not have to recreate them all again! 

Any ideas? Anyone?

Thank you in advance.

Greg

7 Replies
Christine Hendrickson

Hi Greg!

First thing I would check is the location of the project files. Are they on your local hard drive? Try to make sure you're not editing, previewing or publishing content from any external sources such as network drives, USB drives, etc.

If you've confirmed all the content is local, are you able to try publishing to a different directory? Try the desktop and see if that makes any difference. 

Also, what output method are you using for publishing? Are you able to try a different option, just to see if it'll complete successfully?

Thanks!

Greg Cannon

Thanks for the responses.

Initially the storyline file had been saved on a network drive - I've never experienced any problems with this before and at least my network drives are backed up automatically so it's my preferred option in case of any disasters.

It does seem to be a particular slide that is causing the issue as when I preview each individual slide it's only the 1 that seems to be causing mischief.

Peter - will share file privately.

Cheers.

Greg

Willie Cummins

I encountered a similar problem today with a Storyline project.  However, in my case the project was not on a network drive. Also, Preview would not work on any of the slides - the 'Preparing' progress bar would move almost all the way to the right but then stall without finishing.

As a temporary workaround, I created a blank Storyline project and then pasted in all the slides from the problem project.  I was then able to preview slides in the newly created project and was also able to publish the project successfully.  

However, this is not a viable workaround in the long term.

Since mine does not appear to be an isolated incident, I was wondering if this issue being actively worked within the Articulate Storyline team?

Thanks,

Willie.

Ashley Terwilliger

Hi Willie and welcome to Heroes! 

It looks like you did the first step of troubleshooting by following the directions here to import into a new file. So the next step I'd have you try is to conduct a simple repair of your Storyline software, and directions are available here for that. 

If that doesn't help you, let us know and you can always submit a Support case so that we can look at your files specifically. 

Susan Menzies

Hi there from Australia!

I've had this problem twice before and have resolved the issue by re-compiling the project - by pasting in the slides again. I have also reinstalled the software.

However, it has happened again and I think there must be a bug in Storyline - of course, it only happens just when I've completed the project and want to Publish!  and it's only meant to be a "quick and dirty" one.

It is not only the Preview option where there are difficulties - when I go to Publish to LMS it seems to finish the "publishing" process but doesn't show the Zip/View dialogue box. In the output folder there are: LMS, mobile, story_content, Temp folders and meta.xml file but the manifest and others are missing.

I hae sent in a Support case when doing one of the projects in April but didn't receive a reply. I will submit another one anyway.