Courses built in SL3 - Error message when taking quiz

I am republishing our courses in S/L 3 but now we are getting an error message when the test is attempted.

An error has occurred managing your lesson data

If you continue your activity may no longer be saved. It is recommended you close this lesson and relaunch it.

Error in Relaunched content

File:  /sco/convergnet/h3ijp/html5/lib/scripts/app.min.js

Line:3

Error: TypeError: Unable to get property 'setattribute' of undefined or null reference.

 

I reported this to our LMS host service and they replied: This is an issue that is definitely coming from Storyline content. We've had a bunch of those lately, so we added additional logging to identify exactly where the JS error is coming from. There has been a recent update to Storyline that has addressed many of these content issues. Try updating your Storyline with the latest update, and republish the content.

 

I appear to have the latest version of S/L 3 Update 6   Help!

7 Replies
Ashley Terwilliger

Hi Andy,

I'd like to have our Support Team take a look at your file and the error code you've seen in the LMS, so I opened a case on your behalf. You'll see a confirmation of this shortly from Support@articulate.com, and that email will include a unique link where you can upload your file. 

Thanks for reaching out here - we'll help figure out where things are going haywire! 

Calvin Lo

we just got this error reported by a customer who has our content on their LMS. when they went to a quiz, the same error popped up. i tried replicating it in our LMS but I can't. I will try republishing the course and have them try again. while i'm doing that, is there any notes in the release fixing this problem? 

btw, quiz from other courses are working fine for them so I don't understand how this particular course is different.

Ashley Terwilliger

Hi Calvin,

What version of Storyline are you using to publish these courses? I took a look at Andy's case and it seems that the issue was specific to Storyline 3 Update 6 and using the Inquisiq LMS. Does that match your setup?

If you're using something different, I'd love to have you work with our Support Team on next steps! 

Ashley Terwilliger

Hi Cecilia,

I took a look at Andy's case and found that our support team spotted a bug in how Multiple Response Question types throw an Error within Inquisiq LMS. We're working on a fix for this that should be available in the next update of Storyline 3. I don't have an ETA on that update's release date yet, but this discussion is now flagged for us to update it here.

This issue only crept up in Update 6, so if you need to rollback to Update 5, please connect with our Support Team and they'll help! 

Joshua Crigger
Popping in here to let you know we just released Update 7 for Storyline 3Here are the details.
It includes the fix we made to remedy this issue with Multiple Response Questions throwing an Error in Inquisiq LMS.
Please download the latest version and let us know if you have any questions, either here or by reaching out to our Support Engineers directly.