Courses Running Slow

Greetings Folks:

I run about 27 eLearning courses on a Godaddy managed server with 1,525 Gb disc space and 4 GB of memory.  All these courses are published to the classic player for customers to either stream or download via the Articulate Mobile app. Recently, I've been receiving customer comments that these courses have been running slow and jerky. I instruct all my customers to use Chrome to view and initially access these courses. All these courses run just fine when they are downloaded for offline viewing. As a final note, many of my courses are about 400 mb when published. Is there anything I mentioned above that immediately strikes you as being problematic and possible for the staccato manner in which my courses are now running? I sure would appreciate any comments or insights you might offer.
Rod Machado

6 Replies
Gerry Wasiluk

Hi!  This documentation indicates how courses get loaded.

Without seeing your courses it's hard to recommend precisely what to do.  Are they linear?  Use a lot of video?

If you have a browser sniffer like Fiddler or HHTPWatch, and you know how to use it, it might be interesting to see, "under the hood" realtime," how things load.

Rod Machado

Greetings Gerry:

Thank you so much for taking the time to reply. Below is a link to one of my courses. This course uses the Articulate player. All of my course modules use video that's finalized in Handbrake to provide the smallest .mp4 file. Most module video files are 30-40 mb in size. I do all my animation in other software to create videos and use very little (if any) Articulate animation in my courses. Last night I increased my server memory size to 8G and this seemed to solve the stutter playing issue for two customers. But I'm still suspicious about this problem. If you get a chance, try the link and let me know if you experience any problems with the first few course modules. I do appreciate your time.

Thank you,
Rod Machado

Gerry Wasiluk

Hi, Rod!

The first thing I noticed is that your timeline for each slide goes on too long.  The duration for most slides is too long.  This can give the impression the course is too slow.

For each slide, adjust the timeline to only be as long as the elements on it needs, which, for your slides, is usually the length of the video.

Here's an old SL2 article on setting slide duration:

Setting a slide duration on a slide with a video on it that plays on longer than it should is a little tricky to set.

I usually bring the ending video into the Storyline video editor to check on its total duration.  Then I use that number to help me set the total length of the slide.


Rod Machado

Greetings Gerry:

Thank you for taking a look at that. I usually run each slide over about 1 to 2 seconds to prevent the video from cutting off before it's finished. This, perhaps, was a habit I picked up when I first began using SL1 (it seemed necessary at that time). With the smaller file-size that I'm now using I suspect I no longer need to add these extra seconds. I also run a rectangular shape over every video for the entire duration of that video to ensure it runs properly. I'll have a look at that article and am most appreciative for the advice you offered here.

Thank you,
Rod Machado

Gerry Wasiluk

You are welcome, Rod.  :) Let us know how it worked out.

Most of the videos ended and the span after was far greater than 1-2 seconds.  A lot greater.  If a video ends a slide, I'll add just 1-2 extra seconds also--but only 1-2 seconds at most, and I'll also make sure the video has the "Show until end" option (set from right-clicking on the video on the timeline).

I also put a transparent rectangle over videos but mainly to prevent folks from clicking directly on the video (which is a kind of  Internet "standard" to pause/restart videos) and the video stops playing until clicked on again--and this almost always throws the Storyline timeline off.  Putting a transparent rectangle over videos prevents that:  to pause a video, users must use the seekbar controls.

One other thing that you may or may not want to consider.  Most videos were fullscreen and I'll sometimes "gently and friendly" push back on folks when they do that.  A lot of times fullscreen videos are really not needed as folks can easily see what is going on with a smaller sized video on the screen.  Sometimes the imported videos, in being made fullscreen on the slide, are smaller-sized and are scaled up so things may look fuzzy or unclear.

Many times a fullscreen video makes great sense--like for the animated characters you are using.  Other times maybe not (like for talking heads).  No real hard or fast fast rules here as it--proverbially--all depends.  And, for this, I always use a smaller player size (usually 960 x 540 as that translates well to tablets like the iPad) to be more network efficient.

One advantage of smaller onscreen videos (in terms of size on the screen) is that translates to a much smaller video file to load, which can help course size and what is required to download all the assets from a server.

Last month, I gave a presentation on using video in Storyline to our local Articulate user group and here's a slide from that preso that sums some of this up:

As for the course assets, looking at the assets download realtime, things seemed just a tad slow but certainly acceptable.  Not inconveniently so--just a tad bit slow.  Could be a server issue or could be a network issue.

That all said, the course slides having too much extra time at the end itself seems the larger issue.

One thing that I really, really liked was your use of the animated characters.  Any way that they could all be the same graphical style?  Most experts recommend not mixing the visual styles of illustrations.

Hope this helps.  Best!