Courses suddenly not tracking in Safari

Our company uses all Mac products and our courses were running and tracking fine up until sometime this month. Unfortunately I am not sure exactly when this happened.  I suspect it is a Safari issue but have no idea what it could be.  The Safari browser on the desktops, ipads and iphones are not tracking when a user passes the quiz and completes the course.

Anyone else experiencing this?  Do you have any information to help us?

Thanks!

11 Replies
Christine Hendrickson

Hi Caryn,

I haven't heard any recent news about Safari having issues with tracking recently. Do you know if you downloaded an update to Safari, recently? First, if there was an update, you may want to make sure that Private Browsing hasn't been enabled in Safari. 

You may find that Storyline's HTML5 output doesn't load as expected in Safari if the Private Browsing feature is enabled.

This is a known issue. To correct it, turn off Private Browsing while you're viewing your Storyline content. Here's how.

If you haven't already, you may want to try testing your course in SCORM Cloud to help determine if the issue is Articulate related or if it's on your LMS's side, or the browser's side. If it appears in SCORM Cloud as well as other browsers, we'd be happy to take a closer look at what might be going on. If you can't replicate the issue in SCORM Cloud, while using Safari, it's probably and issue with the LMS. If the tracking no longer works in just Safari through SCORM Cloud, we may need to take a look and see if there's an issue with the browser. 

Thanks!

Christine Hendrickson

Hi Caryn. I hope you had a great weekend!

Sorry, but I'm a little confused. The testing for AICC instructions above are for SCORM Cloud, not your LMS. Were you able to see the same result when testing the AICC content in SCORM Could, as well? 

If you'd like our tech team can test the files for you. You'll be able to attach the .STORY file on the second page of the following form:

Articulate Support - Submit a Support Case

Please be sure to include a description of your issue. Please also include the URL for this thread in the form. Also, please share the case number with me. You're welcome to do so here, or in a private message. This way I can follow the progress of the case and update this thread.

Caryn Stets

Thanks - you too!

This weekend my LMS company continued work to try and figure out why courses were not completing.  As of Saturday they were not.  Today, the courses are working in Safari but not in Chrome.  

I am going to let them continue their work to see how far they get.  I will definitely take you up on submitting the course if we are unable to pinpoint a cause.

Deborah Munitz

I am still experiencing intermittent tracking problems with my AICC generated articulate lessons on Macs mostly on safari but sometimes on Chrome (see my other post IE 10 updater reply on http://community.articulate.com/forums/p/21617/172908.aspx#172908

I also opened this bug report: 00341443.

I wanted to add to this article because other people with Mac tracking issues might find this first. The majority of the reports are related to the quizzes we have at the end of the lesson. The users all seem to report clicking the quiz's Finish button. Most reports are that the quiz isn't marked as done but some report that the quiz "crashed" or "hung" at the end. When I look at the data captured (we force an update every one minute) I often see that the student has gotten to the end of the lesson and often see the first question or two. So its as if the ExitAu update isn't being sent properly. I have not been able to capture debug information yet on this or recreate it.

The problems I have been experiencing do not seem to recreatable but at this point I am encountering instances of it daily. I have a course with 27 lessons. I haven't been able to establish a pattern yet for the browsers.

The most recent report we had was on our R1 lessons with  BROWSER: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/534.57.2 (KHTML, like Gecko) Version/5.1.7 Safari/534.57.2

This girl reported a crash.  BROWSER: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.116 Safari/537.36

This boy had a problem with LI, SS, S2
BROWSER: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_5_8) AppleWebKit/534.50.2 (KHTML, like Gecko) Version/5.0.6 Safari/533.22.31

This boy had a problem with R1

BROWSER: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_5_8) AppleWebKit/534.50.2 (KHTML, like Gecko) Version/5.0.6 Safari/533.22.3 

Crashing on Mac

BROWSER: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_5_8) AppleWebKit/534.50.2 (KHTML, like Gecko) Version/5.0.6 Safari/533.22.3

So I am seeing multiple Mac OS versions, multiple safari versions. Chrome as well related to crashing. Support is asking for code but its not any one specific lesson and I can't recreate the problem. I am posting this here to see if there are other having similar instability issues on the Macs with AICC LMS.