Data entry variable dropping first letter

Hi everyone, 

I encountered a quirky error.  In my course I have inserted an input field that asks learners to input a business name (variable = %businessname%).

If the learner capitalizes the name of the business, it drops the first name.  If they don't it is there.


Had a similar instance where their name would drop the first letter when I inserted %name% reference.  I fixed this by changing it to %Name%.  

Any thoughts?

13 Replies
Ashley Terwilliger-Pollard

Hi Steve,

I just tried this in my own Storyline file, and wasn't able to replicate the behavior. You'll want to make sure that you're working with local project files, as working on a network or USB drive could cause unusual behavior. Additionally, are you able to replicate this in a new file or is it only happening in this particular Storyline file? I'd suggest if it's just this one file to import it into a new Storyline file.  Are you able to share your .story file with us here? If you'd prefer you can also share it here privately. 

Jane .

Hi Ashley, I just came across this thread this morning- my name variable is dropping my first initial off each word- i have tried importing into a new storyline file (see attached) but it was still happening. I then typed the whole alphabet in to check if it was an issue with certain letters- and it seems that only the letters J and Q are missing....Not a problem unless your name is Jane Quinn! I've also tried various fonts. Can you give me any ideas? thank you 

Jane .

I've just heard back from Articulate support, who have solved the issue, so thought i would update incase anyone has the same in future. Deleting and replacing the text entry box, deleting and replacing the text boxes which contain the references, and changing the font to articulate size 18 has worked for me, so now the full name is visible when the user enters it. You can change the font back to your project font later and it still works. Thanks guys, you are the best. Jane :)