DO NOT Autosize Text Not Working

Hello. When I set the text in a word box or shape to NOT autosize, it does it anyway. This is actually the default setting for shapes. This is most noticeable when used as part of a customized closed caption setup where you can clearly see the text changing size from clip to clip. Anyone have any suggestions on how to make text NOT autosize?

5 Replies
david mckisick

Just an update to this after further exploration. It appears that while a new shape text options appear to default to "Do Not Autofit", this is actually not what it does. Instead, it appears to be stuck on "Shrink Text to Fit". So I think this is a bug carried over from SL1 which never got fixed (I first noticed it in SL1). Has anyone found a way to make text NOT autoresize or shrink to fit when a placeholder text variable is used?

Ashley Terwilliger

Hi David,

Are you using a variable reference to include this text? The box doesn't dynamically update to fit the variable text in the runtime from slide to slide. If you want to be able to show multiple lines without shrinking then you will need to size the textbox accordingly based on the largest amount of text possible. You'll also want to be sure you use the "do not autofit" option than. 

david mckisick

For our closed captioning I have setup a master slide with a closed caption layer containing the closed caption box. In the box I have the text variable that we plug the text into using object placeholders. A single slide could contain many placeholders setup via trigger, "adjust variable (closed caption text variable) when timeline starts on object X". So you see, a single slide has multiple strings of texts going into the variable which then displays the text based on the objects placement on the timeline. Doing it this way, you get the "scrolling" closed captioning in sync with the audio, but the text always resizes so some strings will appear larger, and some smaller depending on how they fit into the provided text box containing the text variable. The text box is set to "Do not autoresize text".

How can we get the text to NOT autoresize using this method?