Does not work with the freeform drag-and-drop

Jun 15, 2017

Can anybody help?
Try running my file.
The slide does not work with the freeform drag-and-drop.

Does not work if you select an option snap dropped items to drop target tile.

If you remove the shuffle answers, the slide works without problems.

Is there such a problem with me alone?
I tried to reinstall Storyline - the problem is present.

17 Replies
Equipe Technique ANEMA


I'm wondering if your drag and drop was made in the first place with Storyline 2 and that you updated it with Storyline 360 ? Because when I did that whith my e-learning I had the same issue than you. I had to make again the exercise with Storyline 360.

See in attachment your file where I didn't touch your slide because what you made is good but still not working. I make again exactly the same exercise than you in the second slide and it works.

I have no more explanations.

I hope this is help you.


Di Kin

When creating exercises such as drag and drop, the error will be reproduced.
The error is repeated in the preview mode. I tried to install Storiline on other PCs. I used Windows 7 and 10. The error is still there.

I repeat. The error occurs when the settings "snap dropped items to drop target tile" and "shuffle answers".
Please give me advice on what to do?

Alyssa Gomez

Hi there Di, thanks so much for letting me take a look at your file. We're working through a problem in Storyline 360 where snapping dropped items to a drop target malfunctions if answers are "Shuffled" in a Freeform Drag and Drop in HTML5. This seems to happen with the "Tile" setting like you mentioned, as well as other settings.

Until we find a fix, you can correct the issue by removing the "Shuffle" setting or by publishing with Flash.

I'm really sorry this is slowing you down, and I'll be sure to post an update in this thread as soon as I get more information!

Traci P

Is this fixed?  I had this issue a few months ago, and now I'm having a similar issue today. My old interaction snaps perfectly when shuffle answers isn't selected. But I just made a new one, and no matter what I do cannot get the snap to work. I've tried everything else I found in the boards as a fix with no luck. 

Katie Riggio

Great news, folks!

To follow up on Alyssa's post, I’m excited to let you know that we just released another update for Articulate 360, and you can check out the new features and fixes in the release notes

One of the fixes addresses an issue in Storyline 360 where drag items did not snap to drop targets correctly in HTML5 output when answers were shuffled.

Simply launch the Articulate 360 desktop app on your computer and click the Update button for each application. Details here.

Let us know how you make out!

Katie Riggio

Hi, Diane. Really sorry that's happening!

Can I confirm what update of Storyline 3 you're on? You can find that detail by going to Help > About Storyline

The current one is Update 3 where we fixed some drag-and-drop issues in HTML5 output, such as drag items would not drop on targets. You can view all the new features and fixes here and download and install the latest version of Storyline 3 here.

I'll be standing by!

Michelle Rosario

Hi there, 

I have 4 groups to drag and drop to 4 targets. 3 are snapping into place but 1 is not. I have attached the .story here. Please be kind as this is a work in progress :)

Slide 1.3 -- It's a problem with the Content Balloon Group and Content Dart. 

Thanks in advance for any support you might be able to offer!


This discussion is closed. You can start a new discussion or contact Articulate Support.