Drag & Drop Functionality in IE 11

This is a new issue for us, but we've had a few users share that a drag & drop interaction is not working for them. This is a card sort activity where each card is supposed to pop up after the previous card has been dropped on the target location. However, these users cannot get the card to drop/snap into the target location and a new card does not pop up, thus rendering the user "stuck."

What makes this even more interesting is that it only does it for some users in IE 11. Our team cannot replicate the issue, even using the exact browser version. We've checked browser versions and that doesn't seem to make a difference. It works fine in other browsers through our LMS and on SCORM Cloud. 

Has anyone else experienced an issue similar to this? If so, how did you resolve it?

21 Replies
Alyssa Gomez

Hello, Bethany!

I can appreciate that it's frustrating when only a few learners are running into an issue, especially when you're unable to replicate the behavior yourself! I'm glad you reached out about this.

Thanks for letting me know you already tested in SCORM Cloud, since that's usually one of the first things I recommend. 

Do you know what version and update of Storyline you used to publish this file? 

Bethany Daniels

Hi Alyssa,

Thanks for the response! I am on SL360, v3.20.16814.0, which I believe is the most recent version. For now, I've removed the interaction in question, but am honestly quite puzzled by this one!  We've looked at IE update versions, and I have the same version as a user who was "stuck," but couldn't get myself stuck.

Let me know if you'd like the source file to tinker with. 

Alyssa Gomez

Hi Bethany!

Thanks for sharing your file. Like you did, I also tested the LMS output in SCORM Cloud. Everything appeared to work correctly! Here's a Peek at my testing. 

When learners report getting stuck on that slide, have you suggested that they try another web browser? If so, does that seem to get them back up and running?

Ashley Terwilliger

Hi Bethany, 

Were you able to share a SCORM Cloud link with those learners who ran into trouble with accessing the course in IE11? It would help to know if it's specific to the browser or the combination of the browser settings they have and LMS. Narrowing it down further would help if your IT team or LMS admin are able to adjust any settings to account for that. 

Candice Phaneuf

I'm having this same issue - drag and drop interactions intermittently not working when users use IE11. Republishing is not an option at this point in our process as the modules have been rolled out to over 10,000 people.

What settings are requirements for Storyline 360 Drag and Drop Interactions?

Katie Riggio

Hi, Candice. So sorry you see some wonky behavior in your drag & drop interaction in IE11, too!

Good thought! No specific settings come to mind, but there are system requirements for viewing Storyline content and what output format is necessary for each feature to work across multiple devices. (I have a hunch you're A-OK here!)

Now, let's dig into some more details. Is your experience similar to Bethany's where learners cannot get the card to snap into the drop target? Also, how are you publishing the course – is it for Web, LMS, or something else?

Candice Phaneuf

Hi Katie,

Its published as HTML5 only for LMS.  The objects never snap into a home, they just sit where you drop them.  Then when you click submit you get the "incorrect" answer.  I have a ticket open with support as well, but they're basically just asking me to do all the things I told them we did already.  I have 6000 people who will be doing these 2 modules next week - i need to figure out the problem.  How can I get me resources on this to help me?

Ashley Terwilliger

Hi Candice,

I took a look at your case, and saw that Cleo has done a bit of testing and has yet to replicate the issue, although your learners were able to with his link. I asked our Senior Support Engineers to take a look, so they'll be in touch soon with next steps! 

Thanks for sticking with us - we'll get to the bottom of it! 

Greg Cebuliak

Hi Candice,

we're experiencing the very same issue! All the drop targets features work within a Chrome browser, but Explorer browsers are an issue - and not ALL IE browsers??

Also, when a learner submits the correct response, the incorrect feedback displays. I may just delete the drag and drop questions and create a M/C....

Our issue here - 
https://community.articulate.com/discussions/articulate-presenter/drag-and-drop-question-incorrect-feedback-displayed-when-correct-response-is-selected

Best of luck!

Sara F

Hi Alyssa,

Any solution on this issue? I am running into the same issue. Drag and Drop question working for some on IE but not others. Users are reporting that the answer is not dropping on target. It is returning to start point. I cannot replicate the issue. Tested correct in IE, Chrome, SCORM Cloud, mobile. 

Thank you!

Leslie McKerchie

Hi Sara/Margit,

Thanks for reaching out and letting us know that you learners are running into a similar issue.

Do you know what version of Storyline you're using?

You can check by going to:
Help > About Articulate Storyline

We are currently on Build 3.29.19305.0 of Storyline 360. You can read all of the details here.

We had an issue that was corrected in Update 19. It was specific to using dashed outlines and no fills for the drop targets.

Thanks for sharing your file, Sara. It looks like your setup matches what I've shared above.

I've published your course to SCORM Cloud and I'm curious if any of the users experiencing an issue are able to replicate with this link.

Leslie McKerchie

Thanks for the additional information, Margit. 

Sounds like you may be running into something slightly different.

With your permission, I'd like you to share your project file with our support engineers to investigate what's happening. You can share it privately by uploading it here. It will be deleted when troubleshooting is complete.

Ren Gomez

Hi Roland,

Thanks for reaching out, and welcome to E-Learning Heroes!

Sorry to hear you've come across this issue. Are you also using dashed outlines or transparency in your interaction?

With your permission, I'd like to take a look at your project file to investigate what's happening. You can share it publicly here, or you’re always welcome to share with our Support Engineers here. They’re available 24/7 to assist!  We'll delete it when done troubleshooting.