Drag & Drop states not changing to correct state

Hello Everyone!

I'm doing what i thought was a very simple drag & drop free form question... The correct answers would change to the drop correct state when they snap to the box that they are being dropped on... However the first and 3rd boxes work fine but the others do not  :(  When done correctly the first letter of each answer spells DOWNTIME .. I'm sure I'm just missing something easy but would love for some feedback because I'm stuck :)

I have uploaded the slide in question.

Thanks so much!

9 Replies
Rob Mcilwain

Strange one Christina!

It doesn't seem to be recognizing the change you have made to the text. Although it is correctly changing to your "drop correct" state as the blue box appears around the outside when dropped in the correct area.

What you could do is copy and paste each red letter into it's own separate text box, then place your new letter over the top of the current red letter in the "drop correct" state. Bit of a work around but will do the job :-)

Ashley Terwilliger

Hi Christina,

I saw the same behavior as you described and it is a bit unusual...I'm curious if you created those boxes in a different way - maybe you were copying/duplicating the elements? Also, can you confirm that you're following along with the other general guidelines here in regards to working on your project files?  When files are behaving oddly, it's also a good idea to try to import into a new project as described here. 

Christina Kelley

Hi Ashley,

I did created them all the same way but i did copy the normal state and then just changed the drop correct state letters..  I am following the guidelines that you listed above as well as I just imported the project into another  new project - and still the same behavior.

I'll try to just delete the drop correct state and redo it to see if it changes - the weird thing is that the D works and the W works just fine from the get go  :(

 

Ashley Terwilliger

Hi Christina,

Did you try this in a brand new file? I've been looking at your set up and trying to recreate it. In a new file, I'm not able to replicate it when setting up a few of the drag and drop items and the states - until I copy one of your objects in. The copied object continues to not behave in the new file - which leads me to believe it's something associated with the object itself and an element of corruption. 

Also, since you're changing the state right when the elements are dropped, there is no need for the triggers you've set up - as the drag and drop has the option to "delay item dropped states until the interaction is submitted" checked off - meaning the dropped correct state will be applied automatically. 

Christina Kelley

Hi Ashley - the reason that i set the trigger is that the first letter of each box is RED -which I want to appear as soon as the user drops the block -  when they are all in the correct order they will spell DOWNTIME which currently only the D and W are behaving correctly... Yes i did do this in a brand new file.  Perhaps I'm missing something??  I have deleted the states as well and re-created them and also started a brand new file...??

Ashley Terwilliger

Hi Christina,

Yes, sorry if I was not clear - when using the dropped correct/incorrect states - their behavior will occur based on how you have identified their correct drop location in your drag/drop set up - so no need for the extra trigger. 

For the brand new file you tried it in, are you able to confirm it is on a local drive, with a file name and path that is under the 260 character limit, and doesn't include any special characters, accented characters or symbols?