Draw from question banks + reset results does not work properly

Hi,

I have multiple question banks of which I draw some (not all) questions randomly and I submit answers at the end. Before submitting, the learner can move back and forth until he/she is satisfied. That all works fine. But if the learner fails the quiz he/she has a possibility to retry. And there is a problem. The command to reset results wipes the radio buttons (I have only multiple choice questions), but the final result is wrong. Always lower than it should be. And I draw 20 questions which at any number of correct answers should give a natural number for percentage. But sometimes I get 11,26% correct answers. That is weird. I think it might have to do something with multiple draws from question banks. Maybe the reset results counts previously drawn questions into the total as well?

Have someone experienced something like this?

I am using Storyline 360.

Thank you

  Elena

7 Replies
Elena Urbanova

Thank you :) And just in case someone would have the same problem:
The issue was that I had previous and next buttons in quiz instead of submit button (in order to submit all answers at once). As I turned on the previous and next buttons for quiz slides, they have generated their own triggers, which is fine. But when trigger for the previous button was before the trigger for next button, it messed up the Passed score count on second or further try. So just make sure that the next button trigger is first and the previous button trigger is second/last.
It is weird problem, but it seems that this way it works.

Katie Riggio

Great news, Elena!

We fixed the issue you reported where the Result.PassPoints variable would not compute correctly if there is a reset result trigger on the slide before the Question Banks.

Here's how you can update Storyline 360 to see all the latest features and fixes. If this problem resurfaces, please record a Peek 360 screencast for me, and I'll be happy to help!

Martin Dean

Please can someone help?

I have a quiz with 20 questions from 4 banks of questions.

Each bank has a results slide and I plot the results on a scorecard showing each sections' achievement.

I want to Reset the results for all 4 results slides by adding 4 triggers to the quiz start button.

I can only get SL to allow me to attach one Reset Results trigger to the button.  The other three remain 'unassigned' and I cannot see why.

I would be very grateful for any urgent help.

Thanks