Drop Down Matching Question Broken in Storyline 3 Since June 2020 Build

Hello,

We have already submitted a support ticket to Articulate with our project file about this issue below. I am posting here because I am wondering if anyone else experienced this issue and what they did to fix it?

We have a discovered an issue in Storyline that breaks drop down matching quiz questions. The issue is that the drop down matching box in the timeline causes the slide to freeze and doesn't load anything after that box appears, and that box only shows 1 out of the 4 matching items.

This issue occurs on all major Web browsers, and only when publishing for HTML5. FLASH works.

I rolled back my version of Storyline to the January 7, 2020 (Build 3.9.21069.0), and the issue goes away. Both the June 16, 2020 (Build 3.10.22406.0) and October 15, 2020 (Build 3.11.23355.0) builds have this issue. We have tested with all three versions of storyline, and only the January 7, 2020 version works correctly.

We attempted to rebuild the slide from scratch using the latest version of storyline and the issue goes away. This is good because it means we can immediately fix the issue that was reported by a user of our training for this specific lesson. However, we have hundreds of storyline lessons, and many of them use the drop down matching template, as well as other drop down style questions. For any future updates to our lessons that require re-publishing with the latest version of Storyline, we are very concerned that we will need to open up every single lesson, search for any kind of drop down type slide and have to rebuild it from scratch. We would rather not have to do this, as we don't have the time and resources to do so. It appears that the June 16th, 2020 build included an accessibility update to drop-down menus, and so it would seem that has something to do with it, since the prior January 2020 build does not have the issue. https://articulate.com/support/article/Storyline-3-Version-History.

Thanks!

6 Replies
Debbie Chaddock

Yes, this happened to me when I updated a Storyline 3 lesson created and published in 2019. A dropdown matching question that had been working fine in 2019 behaved the way Mike describes. The only fix was to rebuild the question using the latest version of SL3. 

Unless there's a fix for this bug, we will need to comb through all our pre-June2020 lessons for dropdown matching questions and rebuild them so they won't break the next time we re-publish them. 

Thanks for posting, Mike!

Lauren Connelly

Hello Mike!

I see that you've reached out to our Support Engineers for help. Great call! It looks like you're currently working with my teammate, Tyler. We'll keep the conversation going in your support case so that we have all the information in one spot. I'll keep an eye on the case to see what the fix is!

Debbie Chaddock

[Articulate Support responded] "...With Update 10 we added our accessible player functionality, with [older] ...projects (and templates) you have the drop-down object set so that it is not visible to accessibility tools. With Update 10 and later we use the new accessible player and with this box unchecked it's not loading the question properly. I've logged this as a possible software bug with my team. They'll be reviewing my report and I'll update you as soon as I have any new information regarding a fix. In the interim, you can simply check that [Accessibility] box and it will allow the object to load properly. Here's a quick peek explaining the issue and also the workaround https://articulate.fyi/3anJZ2e