Dynamically controling text box size and position?

I've inherited a project that has dynamic text boxes. They are all the same small size

http://screencast.com/t/cMqcB1hjU

But upon previewing, they resize and reposition

http://screencast.com/t/cMqcB1hjU

The text is populated from a variable, but I can't figure out how the box is automatically resized and repositioned. Here is the only trigger

http://screencast.com/t/sEctUMQWun4

http://screencast.com/t/nBr646ANK1XP

Any guidance is greatly appreciated.

4 Replies
Robert Lengacher

Steve - Your first two identical links did not provide me with much information, but can you confirm or correct my assumptions?

  • While you are editing the slide, the "dynamic text box" in question appears like this on the slide: %transcript% (See Image 1 below)
  • When previewing the same slide, the "dynamic text box" filled with the text, "Next I will type in the patient's last name." but the text is really small. (See Image 2 below)

If that is the case, then the dynamic text box is actually behaving as it should - it is resizing to fit the text that is in the text box when it is being edited. So when you hit preview the box has a fixed height and width based on the string of text, %transcript%. When the preview opens it does not know there is new text in the box, (which only resizes while being edited), so it shrinks all of the text from the variable reference into the "locked" width and height of the original text box. I know it is a little frustrating, but at least you can now anticipate the issue.

Now for a solution. Try to anticipate the greatest amount of text that the variable reference text box will have when the slide is previewed and manually adjust the size of the text box while editing the slide. The editor will allow you to manually change the width of the textbox, but it will probably not allow you to change the height of the textbox. To be able to change the text box height while editing, do the following:

  1. Right-click the text-box
  2. Select Format Shape from the pop-up menu
  3. Click the Text Box tab on the left
  4. Select "Do not Auto-Fit" in the Autofit section (See Image 3 below)
  5. Click Close
  6. Now you should be able to adjust the height and the width of the text box in anticipation of the text that will fill the box when it is previewed. (See Image 4 below where the width of the text box is the same, but the increased height works better)

With known amounts of text in the variable reference this is easier, but with variable references with unknown amounts of text, this becomes much trickier because it's harder to know how big to make the variable reference box.

Let me know if this answers your question.

Image 1: Editing variable reference text box with Resize Shape to Fit Text selected

Image 2: Preview of slide and variable reference text box with Resize Shape to Fit Text selected

Image 3: Editing variable reference text box with Do not Autofit selected and an increased height to accommodate variable reference text.

Image 4: Preview of slide and variable reference text box with Do not Autofit selected and taller textbox with same width.

Errol Muir

Robert, Steve, I have had a similar problem with work that had been copied from another module I was working on. The problem occurred even after setting 'do not autofit' and allowing the reference text box to be significantly bigger than the variable text box. The text that appears in the reference text box is still minute.

Having done this before without a problem, I wondered if the copying process was causing the problem. I deleted the variable and reference text boxes and re-did them.

Sure enough, everything works as it should (after checking the 'do not autofit' option in both the reference and variable text boxes.

There seems to be a problem that occurs when copying. I wonder if Steve is working on something that has been copied?