embedded MP4 videos don't play on iPad with HTML5

For  a client we have to create an Articulate training that runs on iPad, but they are NOT allowed to use the Articulate player app.

The training holds Flash animations, but we have converted the animations slide by slide to MP4 files (video&audio in 1 MP4), so they would play on iPad's.  

We published Articulate for with the option HTML5 and put the package on a web server.

Unfortunately the animations do not run on the iPad (iOS 6). 

Please see a file with 2 sample slides attached.

9 Replies
carsten lindemeier

Thanks Ashley...but the MIME type was set OK on the Web server.

Also, the videos play fine when accessed from PC.

They also play fine on iPad through the Articulate player app (which we can't use for the client unfortunately).

They just don't play on iPad through the Safari browser via HTML5 pages.

Ashley Terwilliger

Thanks Carsten for the additional information.

Are you using Update 3 of Storyline? Do you have Private Browsing enabled in Safari? You may find that Articulate Storyline's HTML5 output doesn't load as expected in Safari when the Private Browsing feature is enabled. Please review this article for more information on how it was fixed in update 3.

HTML5 media must also be tried by the user to play, as indicated in this chart.  

If you'd like us to do a bit more testing, please feel free to share your file by submitting a Support case. 

Johannes Beier

Want to bring this topic up as we have the same problem as Carsten had a year ago. Is there a solution for the described problem?

We have mp4 files embedded into a storyline course (hosted on a lms server) that works pretty fine on all devices - except on the iPad where the mp4 videos do not start when using the html5 output. It works with the Articulate Player and on all other devices.

Who could help here?

Ashley Terwilliger

Hi Johannes,

Do they not play at all or do they not start automatically?  Videos that are configured to launch in a new browser window may not automatically start playing in HTML5 output. This is a function of HTML5 browsers that can't be controlled. Some browsers will autoplay videos in this scenario, while others won't. If a video doesn't begin on its own, just tap it or click its play button.

If they're just not playing at all, there was a fix for this associated with iOS8 and Storyline 2 as detailed here. 

If you're experiencing something different than what I detailed here could you share a bit more information with us? 

Johannes Beier

Hi Ashley,

many thanks for your quick response. They videos (format: MP4) do not play at all. Here some more information on our testing environment:

- SCORM module has been developed with Storyline 2
- It contains two mp4 videos (no sound)
- Videos work fine on stationary or notebook systems, but not on iOs devices (iOS 7, Safair and Chrome browser tested). The first slide of the video is displayed but cannot be started in any way. Other formats (like AVI) do not work at all in this environment.
- The SCORM modules are hosted in the current version of Totara LMS.
- Putting the SCORM content onto a file server (outside the LMS), the videos are playing as they should.

Are there any known issues in combination with Totara LMS?

Ashley Terwilliger

Hi Johannes,

Thanks for sharing that additional information. You mentioned it worked on a file server, and I'm curious if you've also been able to test at SCORM Cloud which is an industry standard for testing SCORM content. If it doesn't work in SCORM Cloud, we'll want to take a look at the file with the videos.

There are some known reasons here why videos don't play, but since it sounds like your videos are only not playing on the iPad I'm not sure those will match entirely. 

Johannes Beier

Hi Ashley,

meantime we found the error that led to the videos not working on mobile iOs devices:
The SCORM module is provided in Totara LMS via an https connection, however we didn't have a SSL certifiacte installed. This led to the result that the videos were playing without any problem on Windows devices but not on (mobile) iOs devices.

Kind regards, Johannes