End of Video Cut Off

Finally after being frustrated on multiple projects, I have decided to post on the subject.

If I use a few video in a row (one on each slide), I find that during playback, the last few seconds are clipped, making the final audio un-heard. Very frustrating for me, because I use storyline to produce courses with 10 - 20 slides of video.But the end of each slide is missed ...

My solution for the moment is to grab the timeline, and extend it a few second more. However, the results are still rather unstable. Sometimes it is long enough, and sometimes it is not. (Not to mention alot of extra work).

With Presenter this was not an issue. I wish that presenter 2013 was out, so I could switch back. However, since I need an ipad/html5 option, I cannot do so .. yet.

Has anyone else run into this bug? I am sure I am not the only one, because it has come up on every single of my last 20 projects or so. Unfortunately I realized it too late, and now I am getting many complaints from my customers which I must correct for free.

42 Replies
Christine Hendrickson

Hi Eric. Welcome to E-Learning Heroes!

Sorry to hear about the trouble you've had with this. Yes, we have had other reports of this problem and the workaround is similar to what you've used (adding additional time to the end of the slide). 

If you'd like, we'd be happy to take a closer look at it. Please submit a case, including your .story file, so our support team can assist you further.

Also, please share the case details with me, so I can follow the progress and update this thread with the resolution.

Thanks Eric!

Christine

Chris Ammon

We are experiencing the same problem, or hearing it from customers. It only happens every now and then. It is not consistent, but it is frustrating for sure. For me I can only get the problem to occur if I skip ahead in a video that is playing. If I let the video run to the end I haven't had the issue. I'd love to hear a response or fix. Thanks.

Christine Hendrickson

Hi Chris!

I'm afraid I wasn't able to find a case for Eric's issue, so I'm not sure if the problem was resolved for him. Any chance you can share the course with us, so we can see what's happening here? Also, please share the case details with me. I'd like to be able to share any suggestions or fixes for this issue with anyone that experiences the same issues in the future.

Thanks very much!

Christine

Michelle DJ

Has a fix been found for this bug? 

I have been having the same issue and have not found a solution. I exported the same timeline multiple times in a row without making any edits to the story file and the slides with the videos were all cropped, each shorter than the last. I have tried extending the timeline beyond the video end point, but the videos are still cut short. 

Another re-occurring issue that has been happening for me on multiple projects that may be related is: after Publish, the timeline on some slides has been extended (typically by about 20 seconds). Sometimes the issue occurs prior to Publish.

Thanks.

Image of gap at end of timeline on slide

Christine Hendrickson

Hi Michelle,

I'm sorry to hear that you're running into this issue.

You mentioned that you're having reoccurring issues with multiple files. I'm wondering if there's a problem somewhere that's causing all of the trouble. 

First, can you please confirm you're working with local project files? You may also want to check the file names of the videos you're using, if you're inserting them.

  • Work on your local drive (your C: drive). Working on a network drive or a USB drive can cause erratic behavior, including file corruption, loss of audio, and other unexpected behavior. 
  • You should also make sure the directory path to your project files and your published output is less than 260 characters (for example C:\Articulate).
  • Avoid using special characters, accents or symbols in your file names (this includes spaces and underscores).

Additional information regarding "Naming Files, Paths, and Namespaces" in Windows operating systems can be found in the following Microsoft article.

We haven't confirmed the issue originally posted here is a bug. I cannot find any case reports from either Chris or Eric, so hopefully the issue was resolved for them. 

If you've confirmed you're working locally, checked your file names and you continue seeing issues in multiple files, it might be a good idea to check your current version of Storyline. To find this information, click on "Help" and "About Articulate Storyline".

If you're not running version 3 (1305.2012), please download and install the update using the link below:

Articulate - Storyline Update 3

If you still have trouble, please try running a repair on Storyline. If that doesn't fix most or all of the issues, please go ahead and submit a support case with us so we can do some additional investigation. 

Articulate Support - Submit a Support Case

Please be sure to include a description of your issue. Please also include the URL for this thread in the form. Also, please share the case number with me. You're welcome to do so here, or in a private message. This way I can follow the progress of the case and update this thread.

Hopefully we'll be able to get this all working for you soon :)

Thanks!

Nick Wilson

I'm curious if any of the folks who reported this problem ever found a satisfactory solution or workaround.  I'm currently working on a project which uses quite a bit of video, and I've noticed this problem as well.  It seems to me like the issue pops up if the video "skips" or "freezes" momentarily - as it might with a connection problem or slow internet speeds, etc.  Storyline's timeline acts like an unstoppable juggernaut that just keeps on going no matter what, so if the video timeline freezes and starts up again then it is behind.  Storyline ends the video at the point in its timeline where it should end - but the video is maybe a second or two behind where it should be, and gets cut off.  Could be this is totally inaccurate, but that's what it seems like to me.  Anyway, as others have noted above, this issue is quite troublesome.  Extending the timeline is not really a viable workaround if your video does not play through to the end of the slide (as is the case in many of my project slides).  In many cases, there is other content within a slide (audio narration, objects animating, etc.) which picks up after the video ends - making it even more obvious and jarring that the video cuts off abruptly.  Any advice would be much appreciated!

Ashley Terwilliger

Hi Nick,

It looks like this issue was from last year, and I don't see where they ever submitted a case to share their files with our team so that we could take a look. Also, since then we've done a few more updates to Storyline, and we're now on update 5 and the details of that release are here and you can also download that update using the link at the top of the page. 

If you'd like to share your file with us so that we can take a look at the behavior, please feel free. You can share it here in the forums using the paperclip icon to attach it or you can use the links Christine previously shared to send it along to our Support team. 

Matthew Bibby

I came across this same problem recently. I had a number of slides in succession that each contained a segment of a video. The slides were set to advance automatically when the timeline ended. When published, many of the videos would be cut short by a second or two (but not all of them). After discussing the issue with support they recommended that I try the following, which resolved the issue:

1) In Story view, set all Slide Properties->Slide Advances, to "By User".
2) Double-click the first slide with video.
3) Insert the following trigger:
Action: Jump to slide
Slide: Next Slide
When: Media Completes
Object: <Name of the video in the current slide>
4) Select Ok button. Replicate the trigger in the succeeding slides with video.
Mike B.

I just wanted to bump this solution, as I just had to employ in my project, as each of my videos was cut off at the end while playing. My SL2 project file is on a networked drive, which I know is not recommended, so may have contributed to the problem. All of my inserted videos were originally wmv files if that makes any difference.

While implementing the fix, I noticed that one cannot copy triggers from one slide to another. This could be a nice feature.

Chris Ammon

Hi Mike. I haven't had that problem ever since I started working locally instead of across my network. It's true SL works fine across a network in most cases, but since we use video a lot it was just an easier solution to get in the habit of working locally. 

What prompted me to reply, though, was your second comment. I copy / paste triggers from slide to slide all the time.  Are you looking for the copy/paste icons ABOVE the trigger pane? Sometimes I mistakenly reach for the copy/paste icons that are at the bottom of the screen which are just for the layers pane.

Ashley Terwilliger

Hey Mike,

Thanks for the note regarding your videos, and again my suggestion will always be to work locally. If you need to store your files on a network drive, you can certainly do that - and you'll just want to follow the steps here. 

As Chris mentioned I'm also able to copy and paste triggers between slides. You can either click on the element you'd like to assign the trigger to or just click within the slide and you'll see the trigger still appears and is just "unassigned"

If you're having trouble doing this, it may also be connected to working off a network as that can cause odd and untended behavior. 

Mike B.

Chris, that's great to know. Did you also have to copy all of your video files locally, or just your story file? I am working with a LOT of media and it's not really practical for me to copy that locally. I'm going to add a feature request for more compatibility with working over a network.

I tried copying some triggers again, and found that I can copy them sometimes. It looks like I am specifically unable to copy the "Video" trigger created as a fix to the cut off problem, maybe because a different video exists on the target slide.

If I should be able to also copy this trigger, let me know and I will attache a screen capture of it not working. Thanks everyone!

Rachel H

Lars - I am having the same issue with my project. It will run through the video when viewed in the html format (completely fine when previewing in .story file), but when manually skipped through using the seek bar the video is truncated. Any solutions for this issue would be helpful. 

Ashley Terwilliger

Hi Lars and Rachel, 

Thanks for reaching out here and sharing that file Lars. Our team is aware of an issue where the video can become out of sync with the seekbar when the user chooses to seek using the seekbar and other elements are also on the slide (audio files, the rectangle shape, etc.). As they investigate this issue you may want to look into the following workarounds:

I've included this thread in the report filed with our team so that they can continue to investigate. Once we have any additional information to share we'll update you here, but I cannot offer a timeframe for any updates so please continue to utilize the workaround in the meantime. 

Rachel H

Thanks, Ashley.

It seems that setting the slide trigger to "Jump to next slide when media completes" helped the issue I was having, although one has to be wary of the timeline length and media length if you have a seekbar. Setting the timeline to end with the media in your slide is key otherwise the slide might end before the seekbar reaches the endpoint.

Duane Knudsen

Hi all, love the Articulate community! In fact, I tried a Google search this morning just for grins rather than going into the forums first and this thread was the first hit. I published a project yesterday that has 12 short videos in it. Was experiencing the exact same issue where if the seekbar was used the video was clipped at the end. Changed the properties of the slide to advance by user and added in the trigger to jump to the next slide when media completes. Everything works perfect now.

Sometimes we need to allow users to access the seekbar rather than make it read only. This solution seems to work like a charm. Love solutions at your finger tips. Thanks guys!