Entry animations getting stuck

Hi all,

Has anybody else had issue with entry animations on objects - particularly draggable objects?

I have an activity where the draggable objects appear (one at a time) with a "float in" animation. Sometimes, the objects do not move all the way up to their starting position and get stuck part way off screen which makes it look terrible.

I've attached a screenshot here where the purple bottle hasn't come all the way up into the white box. 

The weird thing is it's not any one particular object - if I refresh the activity, then objects that got stuck before now work, and others may now get stuck. 

It's happening across browsers and in the iOS player too.

Any ideas?

7 Replies
Emily Ruby

Hi Erin!

Thanks for sharing the file. I am not able to see the issues on my end. Can you test this output here? Here is a screenshot of what I see from my end.

Can you verify that you are testing in the intended environment? Also, you could try following the steps here if you continue to have issues.

Erin Lawson

Hi Emily,

Thanks for the suggestions!

I've just tried your output on a couple of machines and still running into the same issue. I've also noticed that a couple of items sometimes also come up higher than they're meant to! So some come up too high, others don't come up enough, and it's never the same ones each time.

Yep, I'm testing on the server where it will eventually be hosted. I should also mention that this issue is also occurring in the local Storyline Preview, not just when I publish (see screenshot below).

First object only coming halfway up

I've tried all the steps to uninstall and reinstall SL2 (and all the other components) with no luck. I've also just checked the project on a colleague's computer with SL2 and I'm still seeing the same thing...

Emily Ruby

Hi Erin,

Thanks for the update. We did have several people here test on different browsers and different locations, but could not reproduce the issue.  You might want to reach out to the team with the Web server you are using for some more assistance. Also, it could have something to do with your internet connection. 

If you continue to have issues, you could always reach out to us directly in Support.