Error: Specified argument was out of range of valid values

Trying to save my presentation last night and I received this error.  

Storyline Error

When I clicked OK, the Story View went blank - no slides were visible.  Nothing I did worked to save my presentation.  I couldn't save it to the original location, or to another location, and I couldn't even try to open a new instance of Storyline and copy/paste so I didn't lose my materials.

Eventually I had no choice but to completely shut down Storyline, and when I reopened, everything I'd done since the last save, and some things I'd done prior to saving, were gone, including several minutes of screen recordings.

Has anyone encountered this error, and is there anything I can do to retrieve my data?  

Lesson Reiterated: Save Often

20 Replies
Trina Rimmer

Hi Carrie. I wasn't able to find any reference to this specific error message in our Knowledgebase. Do you know if you have Storyline 2's autosave feature enabled?

Here's a quick walk-thru of the autosave feature. I realize it may not help you recover lost work in this instance, but hopefully it'll save you some agony in the future.

Trina Rimmer

Ah. Glad to hear you've got that enabled.

The auto saved file should open your project in the state of when it was last saved, either by you, or by Storyline's autosave feature. But it sounds like that didn't happen in your case. Could you share this information with our support team? Perhaps they can offer some more suggestions.

Margie Patton

Storyline II
Yes
The only unusual thing that I did yesterday was to “remove all unused recordings,” with a Storyline file open.

Margie Patton
Instructional Designer

11724 NE 195th Street, Bothell, WA 98011
T 425 354 6211| M 206 375 3630
vertafore.com | mpatton@vertafore.com

[cid:image001.png@01CFC6AC.BC49A010]

Alyssa Gomez

Thanks, Margie. Let's get your file in the hands of our Support Engineers so they can help you nail down why this happened. You can send it directly to them here. 

In the meantime,  you may find an older version of your project that contains the two recordings you lost in your temp files. Here's a quick Peek at how to find temp files:

Open this folder in Windows Explorer: Frippdata%\Articulate\Storyline

  1. Scan the contents of this folder for a file that starts with the name of your project. If you find one, copy it to your desktop. If you find more than one, copy the latest version to your desktop.
  2. Change the file extension of the copy on your desktop from *.tmp to *.story.
  3. Double-click the file to open it in Storyline. 
Tarek Ibrahim

It has been 3 years and it seems that this issue still has not been fixed. I've managed to retrieve the file using the temp file trick. However, it is still corrupt and cannot be opened. Please advise. In addition, perhaps your team should look into this bug as its been a few years and its still ongoing?

Ashley Terwilliger-Pollard

Hi Tarek,

I'm really sorry you've run into an issue with a corrupt file. It's an awful position to be in, made only more frustrating by how tricky it is to track down the cause of the corruption. There are a few things that we know contribute to corruption, and the majority of users who follow the best practices outlined here don't run into any of these corruption issues. Please take a look and let me know if you have any questions.

Sadly once a file is corrupt, there isn't anything we can do to repair it. Looking in your temp folders and files is our best recommendation to find an earlier version and then follow those guidelines to prevent any future issues. 

Leslie McKerchie

Hello Nicole and welcome to E-Learning Heroes :)

Thanks for contacting us to let us know that you've run into a similar issue.

It looks like you are using Storyline 360. 

Are you running into the same issue that was originally reported? Are you working locally (typically your C: Drive) with your software and files?

Joanna Matuszyn

Hi there,

I have a problem concerning previewing either slides or entire projects. It coincided with me getting a new Articulate update. The error information says: Specified argument was out of the range of valid values and I can't do the preview of some of the slides or the entire projects. I thought it was a matter of putting in an mp4 to the project but the same thing happens with a different one, where there are no mp4s. Can you please help?

Joanna Matuszyn

Hi Ren,

Thank you for contacting me, I have sent the file using the link you provided. I hope you can help me soon as this is something I'm doing for work and it has already taken up quite a lot of my time.                                                                                                                                                               Am just writing after being contacted by one of your colleagues and the problem is solved! It seems there was one element (which I wasn't using anyway but put aside just in case) which caused all the trouble.  Thanks again for your help.

Stephanie Carrasquillo

Hello, I am encountering the issue with a new project I am working on.  I am using a Storyline template file and when I attempt to save the new Story file, I get the error mentioned.  It seems to be isolated to projects where I am doing a screen recording.  Any guidance on troubleshooting the issue?  I don't want to continue using a template for the rest of the content if it is causing the issue.

Ashley Terwilliger-Pollard

Hi Stephanie,

Looking back on the previous cases for folks in this discussion, it seems each time it was something specific within that file causing an issue. I'd love to have our Support Team take a look so I've gone ahead and opened up a case for you. You'll see a case notification shortly and that'll include a link to upload your .story file.

From there they'll start an investigation and work with you one on one! 

Becca Levan

Hi Diana,

Thank you for reaching out, and I'm so sorry you're running into this. I see that other folks receive this error for reasons specific to their project. So from here, I'd love for you to work 1:1 with one of our support engineers. 

I've opened a case on your behalf, so you should have received an email confirming your case number. Hold tight; one of my teammates will reach out shortly with the next step.

Becca Levan

Welcome to E-Learning Heroes, Harley, and thanks for reaching out!

I'm sorry you're facing this issue. I don't see a standard solution to this, so I want one of our support engineers to step in and take a look. I've created a support case on your behalf, and we'll reach out via email with the next step!