Error with Articulate 360 Desktop Service.exe

Hi All,

I was facing an error to Publish my contents to Articulate 360. After a few trial and error, I found that if and end the Articulate 360 Desktop Service.exe from task manager, I could able to publish.

I also checked this through the diagnose option in the Articulate 360 desktop app. When the Articulate 360 Desktop Service.exe was running, I got plenty of errors. But after closing the Articulate 360 Desktop Service.exe, all was fine in the diagnose option.

If anyone facing the same error could try this option.

Also for the Articulate technical support team, could this error/problem be fixed in the next update?

Thank you. 

3 Replies
Katie Riggio

Hello there, Chirag!

Thank you for sharing what worked for you: Open the task manager and end task for Articulate 360 Desktop Service.exe

I'm sorry for the time lost working through it, but it's much appreciated that you recommended this fix for everyone.

From here, I'm going to give Jopney this information so we can explore further. I'll follow the case and share any relevant details here!

Ryan Smith

I am having the same issue of not being able to publish to review360 as new or a replacement. I tried exiting the program and reopening the file, no luck. I tried to create a new file and copy all of the slides from the original file and then publish, no luck. I tried the fix above through task manager, still no luck.

Ren Gomez

Hi Ryan,

I'm really sorry you've been running into issues publishing to Review 360! Can you confirm that you've tried to publish a completely new file without any of the content mentioned?

I'm wondering if you may need to check your network endpoints to ensure you're properly allowlist Review 360, specifically this one:

  • articulate-us.s3.amazonaws.com

If you're able to share your file with our team, I'd like to have them take a look and see if something is causing the issue within the file. Feel free to upload it to your unique link below.