External certificate not printing

Hello all!  I downloaded some good examples of printing external certificates from Storyline3.  It worked once or twice and then when I click the "print" button to open a window (it is using JavaScript), the window is blank.  I even made sure that the Articulate Projects folder (with the story) had the latest "printCertificate.html" and that the folder itself (and its subfolders) were no longer "Read Only".

Any thoughts on this?  ( I even tried using the Freebie_Print_Cert_SL360 example directly).

 

Thanks in advance.


Deb

5 Replies
Leslie McKerchie

Hi Deborah,

Thanks for reaching out and sharing what you are running into with your certificate.

Are you testing printing out the certificate as your learner would from the uploaded final location? Testing the output locally may not work as intended due to browser security issues.

With your permission, I'd like you to share your project file with our support engineers to investigate what's happening. You can share it privately by uploading it here. It will be deleted when troubleshooting is complete.

Deborah Shapiro

Hi Leslie,

  I just sent a reply to support: 

 I think I have gotten it to work.  Is there an issue editing the printCertificate.html with Notepad++?  It seems to keep settings when I edit in Notepad, although this method is NOT ideal for seeing what is to be changed.

 

Your thoughts?

 

Leslie McKerchie

Hi Deborah,

I'm not familiar with editing the certificate in Notepad++. Can you normally edit .html files in that software?

It sounds like you're not running into an issue printing from Storyline, but it's after editing in Notepad++ that you run into an issue of the certificate not printing?

Thanks for sharing your additional thought with the support team as well.