External Files not uploading when publishing

Hi; hoping for some help.

Using Storyline, I'm publishing (as Scorm) a Storyline file that has 4 resource files (all Word documents).  When I publish, only two are getting published, while for the other two, they are somehow stripped and not published.  

I've tried renaming the files (thinking that might be the culprit) but that doesn't help, either.  The same 2 files get published to the resources while the original 2 do not.

Any thoughts?  Thanks...

4 Replies
Kevin Thorn

Hi Judy,

Few things:

  1. Word documents are iffy by the nature of the document format. Additionally, if a user doesn't have MS Word on the computer they access the course, they won't be able to launch or see the document.
  2. It's best to publish the Word documents in PDF format and allow users to launch and/or download.
  3. If the documents are collaborative (users are able to add/edit), then a Word document in a course will only allow them to download, not re-upload. One option is to create the document as a Google Doc and then insert as a Web Object. Users can then contribute to the live collaborative document.
  4. Filename: Ensure the file does NOT have any spaces or special characters. Where some browsers will read spaces, other browsers behave wonky. My naming convention is to use hypens or underscores between words as a "space".

Hope some or all of this helps.

Judy McDonough

Thanks for your reply, Kevin.  You offer valid best practices about publishing external files as PDF versus as Word documents.  However, that doesn't address the technical issue as to why only 2 out of 4 of the same file-type documents would publish.  Since I'm creating a learning module for use within my company, I know what file types my end-users can use and what types they cannot.

Just for testing sake, though, I did convert to PDF files and all 4 files published fine.  To test further, I switched back to regular Word .doc files and this time all 4 published.  So it seems like a glitch or something.

Now, of course, I'm having issues trying to publish the Storyline Scorm file to Brainshark.  It worked before but now it's not working.