Fill-in on iPad/HTML5 sometimes deletes last character

Hi,

I have now had three different people observe if you are doing a fill-in-the-blank question in Safari on iPad in HTML5 output, sometimes when you press return on the iPad virtual keyboard it will delete the last character of the user's text entry before submitting the question. I have seen this myself and now customers have seen it also.

It does not seem to be easily reproducible, e.g. I can't make a short demo that shows the problem reliably. However when you do a certain publish and the problem occurs on a certain page, it can be persistent. It does not happen on a desktop browser, and you can avoid it if you dismiss the virtual keyboard and then press the Submit button (a custom one in my case). However most users will use the Enter key to submit, and that's when the last character of the entry disappears. (e.g. if the user types "Apple", what gets submitted is "Appl".

Has anyone else seen this?

3 Replies
Christine Hendrickson

Hi Dane,

I haven't personally seen this, but I know that HTML5 can be a bit finicky sometimes. 

If you haven't already, you may want to make sure that private browsing is disabled in Safari. You may find that Articulate Storyline's HTML5 output doesn't load as expected in Safari when the Private Browsing feature is enabled. Please review the following article for more information:

HTML5 output doesn't load correctly in Safari with Private Browsing enabled

Just for testing purposes, are you able to publish for the Articulate Mobile Player and see if the same thing happens?

I haven't been able to find any reports on this, so if you continue to have this issue, please let me know.

Thanks!

Christine

Christine Hendrickson

Hi Dane,

Thanks for trying that out. Actually, I wasn't suggesting you use the Articulate Mobile Player for distributing the course, I was just wondering if the same thing happens through the app on the iPad. 

If you'd like, we'd be happy to take a closer look at what's going on and try to see if we can replicate the issue on our end. I know that it may be difficult to reproduce this, so please try to share as much information as you can with our support team.

You'll be able to attach the .STORY file on the second page of the following form:

Articulate Support - Submit a Support Case

Please be sure to include a description of your issue. Please also include the URL for this thread in the form. Also, please share the case number with me. You're welcome to do so here, or in a private message. This way I can follow the progress of the case and update this thread.

Thanks very much, Dane!

Christine