font size smaller in HTML5 with text variables

Hi,

I have a small problem... It's the word...

When I create a course with a lot of text variable (ex : %name%...) and when I publish in flash and html5, you can see the result :

The first picture is on my ipad in html 5, and the second is on my computer in Flash.

I tried differents fonts (arial, courrier, helvetiva...) Nothing change.

Someone have au solution because, in fact, it's a big problem for me!!!!!!

Alain

61 Replies
Robin Spinks

Hi Adrian and Alain

I don't know if you solved this problem but I also have the same one.

If I view the HTML5 version in Safari or Chrome any text box that contains a variable shows as Times New Roman (probably 10pt by the look of it) and not the Articulate font at 10pt I had set for the text field. This means that my font is now inconsistent with the rest of the text on slides.

As with Alain, I don't want to always use the articulate mobile player.

Let me know if there is anything I can do to rectify this. 

Robin Spinks

Hi

I haven't had time to look for a solution (still trying to finish the session). However, it may be that it is using the default font of the HTML page. So it may be worth looking in the story.html file in a text editor and see if you can change the default font.

It's an idea but only a guess.

Robin

Christine Hendrickson

Hi Johanna!

First, I just want to make sure you've installed Update 2. You can see a list of the fixes for this update here. You can download Update 2 for Storyline here. Please try downloading and installing the update (if you haven't already) and let us know if you still see this issue when viewing your HTML5 content. 

I took a look back at the case originally submitted for this issue and it looks like we weren't able to recreate the problem. It looks like some additional troubleshooting may have resolved the original issue, but I don't see any responses so I can't confirm this. 

If you try installing the update and you still see this, please let us know.

Thanks!

Christine Hendrickson

Good morning,

Doladille, the case I found for the original issue is case #00295010. The last response I see on the case was from Jayem on 9/17/2012. Were you able to take the additional troubleshooting steps that he sent you? From what I understand he wasn't able to recreate the issue, so he wanted to continue working with you to resolve it. The last response contained a link to the article that can be found here. Can you take a look and confirm that you've followed the steps in the article? If you've followed them and still have access to the last email, please let Jayem know that you're still having trouble with this. If you haven't received that last message, just let me know and I can try to forward it to you.

Johanna, thanks very much for the information. Have you tried using a different font, to see if there's a difference in the font size when published? If you still see this after adjusting the font, are you able to share the file with me here, or send it to us privately? We'll take a look and see if we experience the same issue.

Thanks Doladille and Johanna!

Christine

Christine Hendrickson

Hi Johanna,

Thanks for the file! I took a look and I'm afraid I'm not seeing the same thing. I've published the original file and uploaded it here, for testing. I tested this published and uploaded version in Chrome, Internet Explorer and Firefox - the font isn't changing in this case.

I also viewed the HTML5 file, just curious to see if I'd see the same thing if I viewed it locally in all three browsers and it actually displayed properly for me there, as well. 

I even tested this on my iPad. Still displays properly for me. 

Can you tell me a little more about how you're viewing the content and about your system, please? Are you seeing this when you view the local published output for the course, or after you've uploaded it to a web server or LMS? What web browser and version are you using to view the course? Also, what version of Windows are you running?

Thanks again, Johanna!

Christine

Doladille ALain

Hi Christine and Johanna, 

I am very supris when I read that you have no problem on your side.

I found alternative graphics solutions to overcome this concern but it is not exactly what I want. I used graphics state of pictures to show score of anything.

I produce under 2 and articulate update and windows 7 pro.

I'm testing on web platform with ipads 3, 4 and mini.

I still have the same problems.

I even contacted your dealer in France who can not find solutions on his side.

Can you tell me a little more when you publish (what kind of version of windows you use).

Please help us

Regards

Alain Doladille

Johanna Stix

Hi Christine, hi Alain

the course you've provided Christine works for me too. So it's not a browser issue

I've uploaded the same content published with my Storyline Version (UPDATE 2: 1212.1412).

My OS is WIndows 7 Professional 64 bit Service Pack 1.

I published with Web Output, from C-Disk to C-Disk.

I tried publishing with Storyline "Run as Administrator" as well as normally started. Both showed the same result.

I've uploaded the course to one of our webservers, so we can check if you can see the same like me:

html5 test

Hope we can find a solution.

Christine Hendrickson

Good morning Johanna and Alain!

Thanks for the link, Johanna. I agree that I don't think it's a browser issue. I looked at Johanna's link and I do see the issue. 

I am currently running Windows 8 on this machine. I've tested with different browsers, but I don't think the versions will really matter. This looks like it happens when the publishing is taking place. 

I do remember an issue coming up with some fonts not too long ago, but I'm not entirely sure that is related or would cause this type of behavior. It wouldn't hurt to check, though. Please take a look at this article, if you both can. Don't take the steps just yet, I just want to find out if this specific update is installed on your machines. If you both have this specific update, then maybe we can narrow this down and see if removing it makes a difference. Again, though, for now, just try to check and see if you have it installed. 

Also, have either of you tried the troubleshooting steps in this article? I just want to get an idea of what steps you've both already taken so we can see if it might be the same thing causing this issue for both of you. 

Thanks again!

Johanna Stix

Hi Christine

thanks a lot for your helping hand :)

But unfortunately, both articles did'nt help. I don't have dies Windows update, so no need for deinstalling it.

I followed once again the troubleshooting Steps in the second one, but no change in publishing behaviour.

I hope there are some other ideas.

Regards

Johanna

Christine Hendrickson

Hi Johanna,

Thanks very much for trying, I'm sorry to hear the steps didn't help resolve the issue. I think at this point it would be best to work with support on this issue. If you haven't already opened a case for this issue (I haven't been able to find one for you), please use this link to submit a case with our tech team. 

Thanks very much Johanna. Hopefully we'll be able to narrow this down a little further and find a fix for you.

Johanna Stix

Hi all,

till now, support couldn't help.

But at least, today I found a solution for the font size changes:

I'm working with the german windows version and with the local german settings. 

There was a issue in Studio 09 (view here: http://www.articulate.com/support/kb_article.php?product=ap9&id=8b12dewv56kc)

When i change the decimal symbol, at least the font size doesn't change.

However, the font itself does. :(

Christine Hendrickson

Hi Boris,

Can you give a little more information about what's happening for you, please?

Did this start after installing the most recent update (Update 2), or are you running a version earlier than 2 (1212.1412)? To find this information, please click on "Help" and "About Articulate Storyline". 

Also, are you publishing for HTML5, as well? 

Thanks!

Christine