Free form drag and drop issue - learner can't try again

We're in the user testing phase of this project, and I need some help!

I have not had any trouble with my drag and drop and pick many free form interactions. However, I've had several learners report issues like this:

On the Basics tab, check your knowledge section, I was stumped (and couldn’t proceed until I put the objects in the right containers) so I backed up (using the internal screen functions, not the browser’s back arrow) to review the items from the previous section.  When I navigated back to the check your knowledge game, the objects were still in the containers I had incorrectly assigned them to, but I could not move them.  I tried to refresh, start all over, everything I could think to try to no avail.  So I cannot finish.

Now I'm already aware that some of our users are on the minimum supported Flash standard for Storyline, and I thought that might be the issue. However, I checked with a few of the folks who experienced the issue, and they are up to date.

A few details about the set up:

  • Custom previous/next buttons (the next button is not clickable until they get the answer correct)
  • Custom submit button (they answer the question and click "check solution" to which they get "Try Again" or "Correct" feedback. Upon getting it correct, they would move on to the next question. Clicking continue after getting the try again response simply closes the layer.)
  • Unlimited attempts

Thanks in advance!

13 Replies
Rebekah Massmann

Ok, I was able to replicate the issue on my machine. When I navigate completely away from the quiz and come back to it, anything I've clicked to select or dragged to a drop spot can no longer be changed. I would then be stuck because I can't advance until the question is answered correctly.  Thoughts?

Rebekah Massmann

More testing updates:

If I set all slide settings to "resume initial state" it takes away the problem of learners getting "stuck," but then it resets the question if they want to go back and review what they said/what the answer was. And then they can't proceed without re-answering the question, which is also an issue.

Ashley Terwilliger

Hi Rebekah, 

How many attempts do you have set for each of these quizzes? If it's only one attempt they wouldn't be able to change or modify anything, even if they navigated back. Was the previous setting "resume saved state" or "automatically decide"? I typically stick with "automatically decide" as the default as it lets Storyline determine what to do with the course. 

If you're able to share your .story file here we can take a look. If you'd prefer to share it privately our Support team will be happy to look. 

Rebekah Massmann

Thanks Ashley. We were not testing in our LMS yet (though we are starting that now), only publishing for web and emailing the zip file. However, I tested it with the link John sent and was able to replicate, so I'm not sure what's going on. I emailed him back this morning and haven't heard anything yet, but hopefully we can figure out a solution or at least a work around! I'll update the thread as I can.

Ashley Terwilliger

Thanks Rebekah - can you test John's link in a different internet browser and see if you're still experiencing the same issue?

I tested it in Google Chrome, and was able to navigate back and revisit the quiz. Everything was where I had left it, but I was able to move them again (for example on the Intermodel 101). 

Rebekah Massmann

Ashley - Just sent a note to IT because my flash needs upgrading on Firefox in order to view. They should be able to help me soon (I don't have rights to install stuff). However, if it turns out the issue is the browser, that's going to be a problem for us. As with many larger companies, IE is by far the most common browser across all systems and the default for most users. Thanks for your help and follow up.

Rebekah Massmann

Haven't tested in Firefox yet, but did test in Chrome with the same results, using both links John provided.

Can you do me a favor? Can you test it again (or verify that this is how you tested it before) by starting to answer the 2nd question (drag and drop the commodities into the containers), then leaving the quiz, then coming back and attempting to move one of the commodities you already dropped back out?

I'm asking because my internal testers reported no issues at first, until I probed further. They didn't have any trouble adding commodities that hadn't already been dropped, but they didn't try to drag ones around they had already answered.

Thanks for your help.

Ashley Terwilliger

Hi Rebecca,

Happy to test again - here is what I did:

Using the newest link that John sent you - First test using Win 8 Chrome and IE10

I was able to drag and drop items that I had already dropped after leaving the quiz, as when I returned they were all in their original states. I even tried to "Check the solution" mid way through answering (got my correct/incorrects) left the quiz, and returned and they were still all in the original locations, which oddly enough is different than when I tested it the first time. 

I also tested it in Win 7, using IE 10 - same results. 

I see that you sent another email back to John, and I'm not certain if he's been able to test again - but I'll follow that as well and see if he finds anything different. 

Rebekah Massmann

Oh. My. Gosh. So John was finally able to replicate the issue, and would you believe it's the simplest fix?

The hotspots were actually on top of the drag items in the timeline, but I didn't notice because they are of course transparent when the course is played. So anything that was dragged onto a hotspot was actually dragged under the hotspot, and when you revisit the slide, the timeline resets, meaning you can't click on the items because they are underneath the hotspot.

I feel pretty silly now, but hopefully it hasn't been in vain, and this forum thread will help someone else some day.

Thank you for all of your help too!