FTP Crashing with Useless Error Message

I have one project which will just not FTP after publishing. It crashes and locks up SL2. I have to bring up Task Manger to close it.

I guess the bigger complaint at the moment is that a dialog box pops up and says "1 matches total." Sometimes it says "0 matches total.". Does anyone have a clue what this is referring to?

Programmers should have done a better job with this message about saying what happened, or at least tell you that a crash has occurred and how to recover.  

3 Replies
Sharon Huston

Russ, I can't help with the dialog box, but here are a few suggestions for FTP:

1.  Don't use Storyline's built-in FTP.  Instead configure a standard FTP client (like FileZilla) and try it.  I like FileZilla, so I've never used the built-in FTP.  Instead I publish to web and upload the folders with FileZilla.

2.  Have you tried to FTP to a different server to make sure it isn't a server issue?  Is there any way to access an FTP log in Storyline?  (Never tried myself as I don't use it!)

3.  Do you have enough space on the server?  Does your ACCOUNT have enough space?  (The server may have a bazillion terabytes free, but your little parcel may be restricted.)

4.  Have you tried using FTP on one folder at a time to isolate the folder with the problem, then on individual files in the folder?  Once you know what the specific file is you MAY be able to replace it with a file from a previously-published .story.  Look to see if the file names are the same.  

 

 

Russell Still

Thanks, Sharon. Actually, I've been using Storyline's built-in FTP ever since version 0 of Storyline. I do have Ipswitch and have been using it for over a decade. 

Yes, I've checked the server. Other SL projects FTP to it just fine. Something unusual about this particular file.

I'll peel this project down until I eventually find out what's causing it, but error messages like this, issued to users, but of absolutely no value to them are one of my pet peeves. No excuse for it. 

Here's another one I occasionally get after the first one. Obviously it's meant for a programmer. So why are users seeing it? Just frustrated and venting.

Ashley Terwilliger

Hi Russ,

I'm sorry to hear about the difficulty you've run into with the FTPing, but as you mentioned you're able to FTP other files, it sounds like it may be something specific to this file. The "object reference" error is typically one I've seen in regards to file corruption. I'm sure you've checked to be sure you're working locally but have you also tried to import into a new file as detailed here?