Garbled text

I've seen a couple other threads regarding "garbled" text. I'm experiencing something similar, but it seems slightly different, so I thought I'd start a new thread.

I am working on a course and the client is reporting "garbled text" when they test it. I am unable to replicate the error, but from the information and screenshots gathered, it appears to occur only under certain conditions, and with certain text.

1. It only occurs in IE.

2. When the course is launched the first time, the text appears okay. If the course is exited, and then resumed, certain characters are replaced and spacing becomes messed up. It appears to primarily affect punctuation, special characters and ligatures.

3. It is not specific to one font. I have tried switching fonts to no effect. It also doesn't seem to make a difference if the font is plain, bold, or italic.

4. The course began life in SL2.

The client is using Plateau for their LMS. I do not have access, so am unable to test or troubleshoot from my end. I have loaded the course in SCORM cloud, but have not been able to replicate the issue.

All thoughts/suggestions/support are appreciated.

17 Replies
David Oskorus

Hi Jon-

Thanks for the suggestion. I had tried that to no avail.

After a couple of months of trial and error of anything that I could think of (and lots of banging my head against the wall), the client moved the content to a different server. (The content server is separate from the LMS). Whatever the difference is between the two servers—Presto!—it is no longer an issue.

Still don't know the underlying root of the problem, but at this point I'm quite content that it appears to be resolved.

Thanks!

Katie Riggio

Welcome to eLearning Heroes, Sue!

So sorry you're running into this, and smart move to open a support case. For first steps, I see that my teammate, Gerald, shared this article about why missing letters and wrong fonts might appear as well as how to determine if the issue is with Articulate content or with the LMS.

Please let us know how you go, and we'll explore further. I'll also follow the case so I can share any insight here, too!

David Oskorus

Hi Sue-

Sorry, in this instance I haven't been able to determine the differences with the servers or really figure out a fix other than "well, it's working now, so..." And we've been using SL360 & SL3 long enough now that we are no longer really seeing many courses started in SL2 and moved into SL3/360, so we haven't really seen it again.

Again this was where only certain characters and ligatures were being swapped out and spaced weird.

One thing that might help is switching to Modern Text
Design > Font > Use Modern Text

Be aware that switch to Modern Text can cause some changes to occur in your text such as character wrapping or color shifting. I've found the changes to generally be minor, but significant enough that I need to go through and adjust a few things after switching.

We have also seen some similar but different problems as well. In these cases, the font usually is completely substituted with something generic (like times).

If that happens, Gerald's suggestions are things that I would recommend, as well as clearing out the users cache. I've viewed a course where everything was fine, then after republishing and re-posting, all the fonts changed. It ended up being the browser, and clearing the cache fixed the issue.

Good luck!

Katie Riggio

Thanks for sharing your latest findings, Sue!

I added the Storyline 2 detail to your support case; great troubleshooting! If you could share your .story file with Gerald via this private upload link, that would be gold! We'll test it in another LMS environment and let you know what we find.

Gerald is standing by, ready to help get to the bottom of this issue!

sue dingle

Hello, Please see attached SL3 file - SL2 files are fine on our college server. 

Web Open Font Format (WOFF) files are enabled on our server. I also have my own web hosting and can read SL3 and 360 files fine. I expect that as our College server is looking for Open Sans 200, which as I can see from Google doesn't exist, then this might be causing this scrambled text.

sue dingle

Hi David,

Many thanks for your reply. 

I think I can now take a reasonable guess on the cause.

SL3 and 360 software are looking for Open Sans 200, which when you look it up on the Internet does not exist as a Web Font. Like you found the font usually is completely substituted with something generic (like times); however, I think our College server doesn't know what to do and doesn't replace the font even though Web Open Font Format (WOFF) files are enabled on our server. Hence why my personal hosting, plus I expect Scorm Cloud would have no issue reading the learning object. I have ruled out most other explanations.   

Thanks

Sue 

 

sue dingle

Video demonstrating the issue

https://drive.google.com/open?id=1YTdbDbyKHha4D7rRpERMuMjnQUomYuOZ

Tested 

Same issue regardless of browser or operating system

Issue does not appear on private web hosting

Version of Moodle makes no difference

This is not a Moodle Theme Issue

MIME type on the hosting server for Web Open Font Format (WOFF) files is already installed.

Storyline suggest using ‘modern text’ in the software however, both myself and many others on the Internet forums have tried this and it makes no difference.

I need to figure out a web-safe font back-up plan which avoids unexpected behaviours? For example serif or sans-serif to the end of the list?

Kind Regards

Sue