Having trouble getting a NEXT button to appear after video

My client would like a NEXT button to appear only after the learner has viewed the complete video.

It seems like I'm doing everything right, but it's just not working... I added a button and started with the state as Hidden. I imported a video, then added a trigger to the video to change the state of the NEXT button to Normal when the media completes. But when I publish, it's just not happening. The NEXT button stays hidden. What am I missing? Is there another way to do this? Or is this a known issue?

Please advise ASAP,

Thank you!

Ellen

11 Replies
Adrian Dean

Hi Ellen,

You could extend the timeline of your slide and the objects on that slide first. Make sure to keep your video's timeline the same. Then I would create the button on a layer. Then I would adjust the timeline of that button so that it appears after the video's timeline on the base layer or slide. Then you wouldn't have to worry about whether all your triggers are interfering with each other, which is probably the case here.

I've done some tests doing just that and they work incredibly well. So if done right, your custom next button will appear just after your video is done.

Hope this helps,

Adrian

If you want to do triggers, if you could post your file here, I can take a look for you. 

Adrian Dean

Hi Ellen,

Two options:

1.)I'll make a video or two showing the timeline option as well as the trigger option and post them here. It will take me a little while to get the scenarios setup and the videos recorded and posted.

2.)I don't have an easy way to get the file to me other than using a service like dropbox or google drive. You could upload your file there. I'll PM you my email address. You send the link to the shared file to me in an email. I'll download it and take a look at it that way.

Either option is good to me. Let me know if you want the first one or the second one here.

Adrian

Adrian Dean

Hi Ellen,

Looking at this it looks like your first video with your next button that appears after watching it is the problem you are talking about. So I click on the smaller low res video and watch it. As soon as it finishes, the next button appears. When I try to click on the button, it won't go to slide 1.2, the congratulations slide.

Your problem was that your button 3 (next) timeline's ending wasn't matching up with your video's ending timeline. So while the next button appeared after the video ended, the timeline didn't go any further and the button's trigger function never became available.

What I did, was match up the button 3 timeline with your video's timeline from start to finish. Your triggers you had setup work perfectly. By doing that, when I clicked the next button it actually moved to the next slide.

Hope this makes sense,

Adrian