Hey Storyline, stop transcoding my MP4 videos, please.

Jun 23, 2017

Hey there -

I am creating a series of eLearning Storyline modules that contain long video clips that I have encoded meticulously to get acceptable quality with the lowest bitrate possible.  However, I notice that when I publish my Storyline courses, it transcodes my MP4 files to BIGGER files.  For example, one source video is 17MB and when transcoded by Storyline, the output MP4 balloons to 25MB.

Is there any way to get Storyline to NOT transcode the MP4 file and just leave it as is?  If not, I may have to re-encode the original videos into a higher quality source format to avoid the "garbage in, garbage out" problem from transcoding one lossy format to another.

Alternately, can I get away with simply replacing the published .mp4 video in the "story_content" directory with a renamed copy of the source video?  I prefer to not do that, as it's going to add a lot of grunt work to do this with every publish of every module.

You would think Storyline would be smart enough to know when a piece of media is in a "compatible" format already and not re-encode it.


5 Replies
Mark Marino

Hi Leslie -

Thanks for responding.

We are, in fact, still on Storyline 2... migrating to newer version later this year. 

I did discover when playing around with the Video Quality slider, an "undocumented feature"...  if I set the Quality slider to 9, then Storyline copies the videos as-is to the published output.  I'm assuming it does that b/c my MP4 files are compliant with the encoding SL expects to see.  Not sure if the publish options clarify this in SL3/SL360, but I'm hoping so.

I had to do some sleuthing around to figure that out, and I'm not sure if that's even how it is "officially" supposed to work, but it would be good if that were documented somewhere.

If I hadn't discovered that feature to leave the source MP4 files alone, I would have gone through a lot of extra work to encode my videos to  higher quality "source" files knowing they were going to force-encoded to .mp4. 

In poking around the links in Justin's response, I did stumble upon this link:


Which says...

Compression: Choose Automatic from the drop-down to have Storyline compress your video files when you publish your course. Choose None if you'd prefer not to compress your video files. Video quality will be higher, but it also results in larger files. (This feature is only available for MP4 videos created with baseline, main, or high profiles. All other video files will be compressed when published.)

Somehow I missed that option to choose None there, and instead assumed the publish settings were the only place to specify video encoding options. 

Thanks for pointing that out to me!



This discussion is closed. You can start a new discussion or contact Articulate Support.