27 Replies
Robert Lengacher

Michelle - You can really hide and unhide it using a trigger, but you can just add a condition to the Next button trigger that disables it.

  1. Create a True/False variable that adjusts to true when the user clicks whatever should be clicked.
  2. Double click the trigger in Trigger pane that says "Jump to next slide when user clicks the Next button."
  3. In the trigger dialog that opens, click "Show conditions"
  4. Below the large "On Condition" box, click the green plus sign in the lower right corner.
  5. Then in the condition dialog apply the following settings
    List: Variables
    If: (select the variable that should be adjusted)
    Operator: == Equal to
    Type: Value
    Value: True
  6. Then click OK
Ashley Terwilliger

Hi Michelle,

It looks like Robert has you covered here, but I also wanted to share a link to a support article that walks you through the steps as well on how to set this up. If you really need the "next" button to not be visible to the user until they've interacted with all elements, you'd need to add it as a custom button on the slide itself as the player buttons or functions can't be controlled by trigger.

T S

Just an added note to the support article Ashley mentioned.  In order to make sure the slide did not automatically advance after the video (or whatever you set it to) was done I had to:

1) View my slides in "Story View"

2) Select the slide.  Had to select each slide individually :( (If anyone knows how to do this in bulk let me know).

3) Under "Slide Properties" change the  Slide advances pull-down menu to "By user"

After setting that the slide only advanced if the viewer clicked the Next button, after the video is complete, as shown in the support article. 

Ashley Terwilliger

Hi TS,

Either a new variable for each slide, or reset it at the start of the timeline for each slide - which method you choose depends on if/how you'd want them to experience the slides on a revisit. 

Also, just as an FYI replying via email includes your signature here so you're welcome to edit the post to remove that information if you'd like. 

Ashley Terwilliger

Hi Karen,

The link still works for me (in my last post with a hyperlink) so I'm not sure what you're experiencing but I copied the info here below:

You can prevent users from advancing too quickly through a Storyline slide, using either of the following methods:

  • Disable the built-in Next button until they've met certain conditions, such as clicking all the buttons on the slide or listening to all the narration.
  • Remove the built-in Next button and create your own custom button for navigation.

We'll look at each of these options below. (If you need to restrict navigation throughout an entire course, take a look at this article.)

Temporarily disable the built-in Next button
  1. Create a new True/False variable, and set its initial value to False. For example:
  2. Then add a new trigger to the slide that adjusts the value of the variable to True when a specific event has occurred.  Here are a few examples:Lastly, edit the "next slide" player trigger to add a condition, so that the Next button will only work if your True/False variable is True. The condition would look something like this:
    • If you want users to interact with all the hotspots on a slide before advancing, take a look at this article.
    • If you have several buttons on the slide and you want users to click all of them before continuing, set the trigger to execute when the states of all the buttons are Visited:
    • If you want users to listen to all the audio or view an entire video before continuing, set the trigger to execute when Media completes
    • If your slide doesn't include audio but you want users to wait until the slide's timeline has completed, set the trigger to execute when Timeline ends
Brian Allen

It's definitely possible to hide the next button and code it to appear.  You can test this very simply by:

  1. Creating a slide,
  2. At the beginning of the slide set your state of the Next button to hidden
  3. Add a shape to your slide, like at the 3 second mark
  4. Create a trigger to change the state of the Next button to normal at the beginning of the timeline of your new shape from step 3
  5. Preview your slide

 

Stephanie Warnock

Hi

I've followed the below video on how to disable the Next button until all the hotspots on the slide have been clicked, but it still won't work for me:  

https://en-uk.articulate.com/support/storyline/how-to-disable-the-next-button-until-users-have-interacted-with-all-hotspots

I've attached a snippet of all the triggers I've created.

Can anyone tell me where I'm going wrong?  Any help will be much appreciated.

Thanks,

Stephanie

 

Mary Ann Kowalczyk (Hagemann)

Is the Next button failing to disable or is it failing to become normal?  I've worked a lot with variables since creating this initial post.  What I do, is this:

Change State of Next button to Disabled
  When timeline (of current slide) starts
  Condition: Flag1=False OR Flag2=False OR Flag3=False.    (make sure you use OR, not AND)

When user clicks button1
   Show layer (or lightbox or whatever you want to happen) 
   Set Flag1 to True
   Change State of Next button to Normal
       Condition:  Flag1=True AND Flag2=True AND Flag3=True (make sure you use AND, not OR)

When user clicks button2
  Show layer (or lightbox or whatever you want to happen)
  Set Flag2 to True
  Change State of Next button to Normal
    Condition:  Flag1=True AND Flag2=True AND Flag3=True (make sure you use AND, not OR)

When user clicks button3
   Set Flag3 to True (or lightbox or whatever you want to happen)
   Change State of Next button to Normal
       Condition:  Flag1=True AND Flag2=True AND Flag3=True (make sure you use AND, not OR)

 

Stephanie Warnock

Hi Brian

Happy New Year!

The Next button simply won't work.  I've clicked all the hotspots which open individual lightbox slides, then the Next button and it doesn't progress to the next designated slide.  I even tried selecting only 1 hotspot at a time then the Next button and it still didn't work.  I've created a hover state of the Next button which does work as expected though.

I have added further hotspots on the lightbox slides, but I don't see how these would effect the Next button?

Thanks,

Stephanie

Brian Allen

While you're troubleshooting this issue you may consider adding some variable references to your slide so that you can confirm your triggers are properly changing your lightbox variables to "True".

Here's a link explaining how to display variable references if you're not already familiar with it - https://community.articulate.com/series/articulate-storyline-2/articles/adding-variable-references

This can be especially helpful when troubleshooting and many times helps me identify which trigger isn't working, which then hopefully leads to figuring out why it's not working...

Again, if you can post a .story file that has this same issue we can help troubleshoot.

Good luck!

Mary Ann Kowalczyk (Hagemann)

If you are checking 6 different hotspots, you need some kind of action to set the Next button to Normal.  Just setting the variables to True won't do it.  You need an action for CHANGE STATE OF to work.  So, you need to check all 6 variables for TRUE Each time you click the hotspot, since you might click them in a different order... I just say CHANGE STATE OF Next button to Normal on the condition that variable 1 2 3 4 5 and 6 are True.  Before that you need to set the variable to true right beforehand.  You need to do this on each button/hotspot.

You might want to try rearranging the order of your triggers.  If you check for True, THEN set variable, then it will not work.  

Stephanie Warnock

Hi

Thank you all for replying, however after spending even more time on it I still can't get it to work.

I've added your suggestion of variables references Brian, and it turns out that the hotspots weren't changing to True once they were clicked for some reason.  So I changed the trigger to 'mouse hovered over' instead of 'user clicks', and now they do change as expected.

I've also added your trigger suggestions Mary Ann, and re-ordered all the triggers to what I think is right, but I like I say it's still not working. 

The button disables as expected but won't change back to normal.  I think it might have something to do with the 'Change State Back to Normal' trigger, as I'm not sure what to set the 'When' to? 

I've attached the .story file.

Thanks again for the support.

Stephanie

Wendy Farmer

Hi Stephanie

I have updated your file using offstage objects to control the mouseovers and the next button.

Also your triggers were set to when timeline starts on the 'next button' .

See if the attached works for you