Hotspots From Other Layers Selectable When They Shouldn't Be

Feb 07, 2018

I have a slide with several layers. As the user progresses through a series of menus on a keypad display, each slide has a hotspot that the user clicks to advance to the next layer on top of it. After progressing to the next layer, the hotspot from layers the user has advanced beyond are still selectable, which brings the user back to a previous layer. This only happens in export - not in Storyline preview. 

For Example

Press 1 (has a hotspot which leads to) - > Press 2 (has a hotspot which leads to) -> Press 3 (has a hotspot which leads to) -> etc

But if the user selects the number 1, while on layer "3", they are sent back to layer 2 even though there's not a hotspot for layer "1" on that layer. I have dozens of slides with this exact setup, and this is the only slide behaving like this.

Any thoughts? I've attached this slide from my course so you can see how I've got it set up.

6 Replies
Ashley Terwilliger-Pollard

Hi Barrett, 

Thanks for sharing your file so that I could take a look. I tested it in preview and I published it for Web, and both worked normally for me. (I had to use the hints - thanks for those!) but it seemed to advance me to each subsequent layer. Can you take a look at the example I've upload here? 

If it's not working for you, please let me know what browser and what action specifically isn't working. 

Barrett Hillenburg


Its still behaving the same way for me. I'm using Google Chrome v64.0.3282.140.

I'm attaching a video of what's happening for me. 

After the learner selects 2 it moves them to another layer, where 2 (or the hotspot over 2) is no longer visible or selectable. However, if you click the 2 button, it takes you back to that layer every time. The same behavior happens with any "old" hotspot after advancing beyond it.

Ashley Terwilliger-Pollard

Hi Barett, 

Thanks for the video - that was really helpful. I took a video of my own experience as well, and you'll see here at my first attempt I successfully navigate through the entire interaction correctly (after learning how to do it!) and then I refreshed it for a second attempt and clicking on the 2 when it was incorrect showed me the try again layer as I expected. 

The difference I'm seeing is you're experiencing this in HTML5, whereas mine is working correctly as I viewed the Flash output. 

So it does seem to be a possible bug in Storyline 2, but I'm having a hard time pinning down what it could be specifically. I did take a look at trying to recreate this behavior in a new file, and that one worked normally in HTML5 (very simple example here) where clicking each box goes to a new layer, and changes a color of the boxes. I can't replicate the issue of clicking back a on an earlier box to see the previous layers. 

I also tested out your file in the newest version of Storyline, Storyline 360 Update 12, and that one also worked with the HTML5 output. You can see that here if you'd like. 

Can you tell me a bit more about your process? Are you duplicating the layers and hotspots, or adding them anew? That way I could narrow down further what's happening in your file to report it to our team. Also in the meantime, you can let users know that viewing the Flash output allows it to behave as expected. 

This discussion is closed. You can start a new discussion or contact Articulate Support.