Hover State Text Box Problem

Feb 22, 2013

I am creating a piece with a series of icons surrounding a central figure.  When the user hovers over the icon, I have created a hover state of a text box displaying with information.  

My issue is that some of the objects on the slide are appearing on top of the text box - the hover is there - it is just below other objects...  I have tried to move all the icons on the main layer to the back, but that doesn't help...


8 Replies
Brent Berheim

Thanks for your question, Donna!  Poor description on my part...  It is a customized hover state.  And I am finding as I keep playing that it does seem to have to do with the order of things on the slide...  The object is like a clock, and I am hovering over each of the numbers - with a text box appearing describing the icon.  I might have to just make the text box appear covering the center of the circle - which, if that is the case, then I just put the object in the middle of the circle at the back...  Not optimal, but could work, I think...

Any other thoughts?

Donna Morvan

I suggest you make use of layers. This way, you can guarantee that it will always be over all the other objects on your base slide and you'll have freedom on where you want it to show.

Just add a trigger on the objects to show the layer when they hover over it. Doing it this way will also give you more options in terms of animation and look of your text box.


You can also just make use of "markers".. you can put audio and video in them too..

Check the file

Hope this helps.


Ben  Wyse

Brent, Can we see the file or a published demo?

The order of the layers will affect how the hover displays.  For example, if your hover object is on a layer below another graphic object, any hover text or graphic will display under this graphic object when it is published.    Many times I will put my base graphics on the Slide Master to get them out of the way.  

Patricia McQuaid

I'm having problems within a layer that contains both an image and a text box.  I've created a customized state so that when I hover over the image it's enlarged.  This works lovely until I preview it and then the text also appears in the hover state. How can I stop the text from appearing on top of the image?

This discussion is closed. You can start a new discussion or contact Articulate Support.