Hover states appear on text boxes with no hover states after translation import.

Random text boxes generate hover states when there are no hover states. This only happens after I import a translation document. The original storyline file does not contain the hover state errors. 

Is anyone else having this issue? I think it's only been happening since the latest update.

24 Replies
Leslie McKerchie

Hi Dana,

Sorry to hear that you're running into an issue. I'm not sure that I've heard of this happening.

If you import the project into a new file and do the translation export/import again or in a different file are you seeing the same behavior?

Would you be able to share your .story file so that we can take a look? If you have the original file as well that would be helpful.

Kendra Davis

I am having the same issue as Dana now as well.

Here are some particulars for the course: It was originally created in SL2, but has since been updated to 360. I exported the course for translation as a Word doc on 10/16/17 which would have been under the October 12th 360 update (Build 3.9.13567.0). My PC (Windows 10) currently has the December 15th update of Storyline 360 (Build 3.11.14249.0).

Here's the issue: My team has been experiencing an issue where blue boxes appear as we hover over text that has at no time been assigned a hover state. My primary job is translation, so I have encountered issues with blank screens (this seems to have been fixed in the Dec. 12th update-thank you!), missing triggers (which we are usually able to troubleshoot on our own), etc.

I simply don't have time to re-copy/paste every text box that is experiencing this hover-effect issue and then reformat it all again (our very time-consuming work around). I am requesting that your team work to resolve this issue asap. There does not seem to be any kind of rhyme or reason to this issue from my end as it appears on some slides but not on others.

I also do not believe this is a problem with our translation providers as I currently have 4 different people providing translations for our team. And the provider for this particular course I've attached is different from the provider for the courses Dana has been having problems with.

Thank you for your help, let me know if I can be of any further assistance. I attached the English and Translated versions of the course to case #01194657 so you can hopefully see what we're seeing. 

Kendra Davis

Thank you! 

Here's another solution found by a member of our team.

"I found a quicker way to remove the weird hover states on text boxes when you import a translation file. For some reason, it is thinking the text boxes are hyperlinks, so if you highlight the area with the hover and right click, it should give you the option to “Remove Hyperlink” and that will get rid of the hover state.

Keep in mind, you have to select the text that is being highlighted when you hover, so there might be multiple “hyperlinks” in each text box.

Not ideal, but it seems to be faster than creating a new text box or copying/pasting."

Andrew Hanley
Phil Mayor

I have seen this typically a green text hover, you can normally fix by removing all formatting on the offending text boxes

 

Thanks Phil! This fixes it for me, but its definitely an issue (and a big one for us now!).

Unfortunately, I would have to go through approximately 400 text members, in 6 courses and manually do this for each one!! So not a solution that is viable for me.

Ive worked out when it happens though...

It happens when you IMPORT TRANSLATION from a Word document.

For some reason, Storyline is applying some sort of formatting to the import which gives it this "hover" state when it never had one in the first place.

As if this werent bad enough, it means that any buttons under the text no longer work, as the mouse click is being captured by the text member now, and therefore doesnt trigger.

Alyssa Gomez

Hey Andrew,

I took a peek into Dana and Kendra's cases, and I don't see that we were able to recreate this hover issue after importing a translated Word document. 

It sounds like you've seen this happen consistently, though, so I'd really like our team to have a closer look.

Would you mind sharing your unpublished Storyline file and the translated Word document with us by clicking here? Thanks!

Lee Webber

Hi, I'have had this exact same issue today after translating a course using the import word doc feature. If you make any changes to the text in a text box, the entire text box become a hyperlink and turns purple on roll-over in preview. I tried the right click solution but could not find any hyperlinks to remove, the only way I could solve this was to copy the translated text to notepad, delete the text box, insert a fresh text box and paste the text back in - resolved. This also happens to buttons. I have raised a case with support as clearly 12 months on since this first reported and still happening.

Katie Gokhshteyn

I'm so sorry you've come across this oddity, Lee. 

Great call to reach out to our Support Team where I see my teammate, Richard, is carefully assessing this behavior. You should hear back from him with some next steps shortly.

You're in good hands there, and I'll also follow the case as it progresses so I can share any additional insight here. Thanks for reaching out!

Katie Gokhshteyn

Welcome, Jouko! Sorry to hear you're at this roadblock.

In Lee's support case: We found that an imported translation document created a hyperlink for some text boxes which caused the hover state to appear when editing the text. While our team continues to investigate this oddity, I see we recommended to remove the hyperlink when editing a text box. 

Does that match what you see in your project file? With your permission, we'd like to verify and help test your .story file. If that works for you, please use this private upload link. We'll let you know what we find and will delete the file after.

If there's anything else I can answer in the meantime, I'll be here!

Enes Karahasanovic

Hi guys,

we also came across this problem. It is definitely a problem when importing the translation file (in our case WORD documents). For us this happens when making changes inside the text box after importing. As soon as you add another character/space/etc. inside the text which is imported from the translation file, the text box will get this stupid blue highlight when hovering over.

As Phil said, you can remove the Formatting from the text box, but this is not a permanent solution. Actually, this creates another problem because it changes the size of the font as well, which we have to reset after removing the Formatting.

Is there any solution from Articulate Support??? Above I only see authors bringing proposals but nothing concrete from you guys.

Crystal Horn

Hi there, Enes. I can tell this is frustrating. I couldn't reproduce the blue highlight when hovering over the edited, imported text with a western language. Can you let me know what language you translated to?

We're also happy to take a look at your files. You can share them privately with our team here.