How can I get an MP4 animation to play within the slide on an I-pad?

I was wondering if anyone can help me with the following question I have about MP4 Animations.

Last year I had all my flash animations re-created into an MP4 format. The animations are of various steam components and whilst the animation plays text labels appear to highlight various important parts. As I have a Global audience the text labels are created within storyline, so they can be easily translated. So I need to keep the animation and text separate.

The animations have been inserted into the storyline slide and set to play within the slide. This all works fine for PCS, however on mobile devices the MP4 animation always appear in a new browser, and not within the slide, so the labels aren't visible.

Is there another format I can produce my animations in that won't be treated as a video when viewed in a mobile device?

Is storyline working correctly, as I have set the animation to play within the slide?

Any help would really be appreciated.

 

 

 

 

 

26 Replies
Ashley Terwilliger

Hi Trevor,

What iOS are you using on your iPad? Apple introduced inline playback for videos on iPhones in iOS 10. Earlier versions of iOS force videos to play fullscreen on iPhones - which sounds like what you may be seeing? 

If you are using iOS10 or later, can you let me know what Storyline version and update you're using? 

Trevor Young

Hi Ashley, this is quite a large file.

 

If you could look at slide 3.2. Whilst the animation plays, I have some annotations appearing. It all works well on PC, but on I-pad the animation opens in another browser on top of the slide. The voice over can still be heard in the background.

Trust this helps.

Ashley Terwilliger

Hi Trevor,

Thanks for the file - I found some videos in Chapter 3, so that's what I focused on. If there are other slides I should look at just let me know.

I played it on my iPhone 6S using iOS 10.2 (I'm lazy about updating...) and it played normally and didn't open up in a new tab/window. Can you take a look at my example here? (link removed at Trevor's request)

Trevor Young

Hi Ashley, this seems strange I've now tested this on 2 I-phones and an I-pad.

The slide plays fine until it reaches the MP4 on the timeline then the animation appears whole screen covering the slide below.

The version you have shown here is what I see on PC and works fine. I still cannot get it to work through iOS.

Ashley Terwilliger

Hi Trevor,

So my link played the same as yours did? I'd like to get a few other colleagues testing this too - as the video and elements played normally for me, not covering anything below it. Can you tell me what slide exactly you're looking at? I want to make sure we're testing the same! 

Also, anything else about the iPhone/iPad versions, wifi vs. data, iOS, browser used, etc.? 

Trevor Young

Hi Ashley, getting a little confused as I could only view the link you sent me on my PC. I don't access E-Learning Heroes through my I-pad.

Slide  2 in chapter 2 is one of the ones I need you to look at.

We have tried this on 2 different I-phones and my I-pad and it still doesn't work. It only seems to work on PC.

I'm going to try this again across my home broadband as opposed to my work network to see if this makes any difference.

 

Ashley Terwilliger

Hi Trevor,

You'll need to delete the .story file from the ELH forums - you can follow the same steps in this Peek video  for removing your signature using the "Edit" function and just upload a blank file. I can delete the link and image I shared here - just want to make sure you've got a copy of the link before I do so?

 

Trevor Young

Ashley, just tested using my home broadband, via I- Pad and it still doesn't work.

I tried your link too as I accessed my account via my I-pad, but I cannot play your link without downloading the mobile player first.

The only thing I may check when I'm in the office tomorrow is my publish settings, as I wonder if this makes a difference. From memory I am using HTML with flash fallback. 

I will try to do a screen recording of what I am seeing when I go to work tomorrow.

Trevor Young

Thanks for trying this Wendy, really appreciate you taking time to try to help.

I don't want to sound ungrateful or untrusting but could I just ask you to make sure you delete the story file.

I didn't really want to share this full version of my course, I'm sure you understand.

Kindest Regards

Trevor

Trevor Young

Hi Ashley,

I have uploaded two photos from this morning.

First one shows how the kettle image is shown full screen, When you click done on this, you can then see the slide, but the animation doesn't play.

Second image shows how the labels still appear, but no animation.

I have checked  my publish settings and they are:

HTML5 with Flash Fallback

Use AMP For iOS and Android unticked

Allow downloading for offline viewing ticked

 

The course is housed and played from Cornerstone LMS, do you think there could be a setting within this that may be causing the issue?

Can I just confirm what you mean by the responsive player for HTML5? Thanks.

Is there anything else I need to check for you?

Trevor

Trevor Young

Hi there, I had to leave this issue to the side as I have quite a large project to complete.

I still haven't been able to resolve this to date. The MP4s will not play within the slide.

Hopefully I'll be able to pick this up when I have a little more time.

Ashley has been really helpful though!!!