How to edit the "goodbye" message when the training is done

This has probably been covered in a prior post but there are some tricky details to make this work that I felt I should share all in one place.

When your training program is done, there is a default message that says "The content has ended. You may close this window." For those publishing to an LMS, this may not be what you want trainees to do. This message, however, is not editable within Articulate. You have to edit this message manually, and there is only one way to make this work:

  1. Publish the output of your program as you usually would for LMS. You will get a "Publish successful" popup panel with a prompt to email/FTP/ZIP/Open your output. Normally you would click on ZIP for LMS use -- DO NOT ZIP the project yet! Just leave it at the prompt and do not close out the panel!!
  2. Locate the folder on your computer where the "Storyline output" is located. Inside the main directory is a sub-directory named "lms". Inside this folder is "goodbye.html"
  3. Open the "goodbye.html" file in a plain text editor (NOT MS Word). Edit the message. Use standard HTML to style the message, such as h2 tags, bold, etc. Then save. If you want to test it out to see what it looks like, open the goodbye.html file in any browser (drag the file onto a browser application icon in your dock or just drag the file into a browser window that is already open).
  4. If you plan to re-render your published content and want the same message handy, make a copy of the "goodbye.html" file on your desktop so you can replace the default goodbye.html file that is rendered each time you publish.
  5. Now that you have edited the goodbye message, go back to Storyline to the "Publish Successful" panel and click "ZIP".
  6. Once the ZIP file is completed, upload it into your LMS. You will now see the custom message at the end.

Things you should NOT do:

  • Do not zip the "Storyline Output" folder yourself. It will throw an error in the LMS that the imsmanifest.xml file is not in the root directory.
  • Do not ZIP the project in Storyline, unzip it, change the goodbye message and then re-ZIP it. Same problem as above.
21 Replies
E W

Is it possible to set it so that I can include a link to redirect the user back to the course page?  When I try to do so, it simply opens up a browser, within the current browser if that makes sense (so it opens the course page within the screen of where the scorm was).

Surely (?!) there must be a way to make navigation a little friendlier here....

Steve Covello

I suppose you could put in some HTML with a link back to wherever you want them to go, with a setting for it up to open in a new tab (target="_blank"), except that if you copy the course for whatever reason, the link will remain absolute - not relative to the original course environment. (It could also get confusing with multiple course tabs open at the same time).

There is also the risk that if you are pointing to a URL that you do not control yourself, the IT folks could change the permalink structure and your link would go bad.

I suggest creating a message that describes what to do. In Moodle, I direct them to "Click on the Return link on the upper right".

E W

Many thanks for your response

We have had some users experiencing issues with the blue "exit activity" link not working. Is this a common issue? And is it possible to edit the "exit activity" text? Presumably the latter is within Moodle language customisation, but the issue with the link not working is what is causing us most difficulty at the moment.

Thanks

Steve Covello

I have not yet encountered this problem where the link doesn't work, and I would bet a zillion $$$ that they were using Internet Explorer if that were in fact the case. Either that, or they were clicking on something else that they thought was the "Exit Activity" link but wasn't (we've seen it all).

I recommend that your orientation material or preamble should include recommended browsers with a stipulation to not use IE. OK, I'm off my editorial stump now...

The Exit Activity text is not editable in the Admin. (I suppose if you had root server level access, you could edit the HTML, but we do not have that level of access in our hosting service. Not a good idea anyway, for my money...)

 

Crystal Horn

Steve's right about that, Jo.  Our software can only detect if it's being viewed on mobile or desktop, and if Flash Player is enabled (if it is published to include flash output).

I like Steve's idea about some instruction regarding environments for the best viewing experience.  

For all:  Here's our most updated information for Storyline 360 and Storyline 3 about when the Exit Course trigger might not work.

Ginger Gregory

I don't see this "goodbye.html" screen in my courses. We hide the next button at the last screen of each file, is that why? Currently we are having trouble with our LMS recognizing that the file is complete. They suggested using the "goodbye.html". From what you have said, it sounds like it is suppose to be a default screen but again, I don't see it in my published files. Any thoughts on enabling this and if it will help mark a file complete within the LMS? Thanks in advance for your help!

Ashley Terwilliger-Pollard

Hi Ginger,

Some LMSs display this closing page (the goodbye.html page in your published output) to make sure they have time to process learners' results before the browser closes. Learners can simply close the browser when this message appears. We have steps here to customize it or suppress it, but no steps to turn it on. 

Luan Snyman

What trigger can be turned on or off in order to display (or not display) the goodbye.html bit?

I'm trying to get it to display in Moodle 3.5, publishing the Storyline content for SCORM, but I'[ve had no success in getting the Goodbye 'slide' to display?

If anyone can help, it'd be greatly appreciated.

Thank you and Kind Regards
|Luan|

Luan Snyman

I's using Moodle (3.5), but the goodbye slide never shows.
It's done this since I started using Moodle.

We used LearnDash before, implemented on WordPress, and it never showed either.
Hence my thinking that it must be a trigger or switch of some kind :\

[Email-Signature---Enovation---Luan-New]

A S

I was asking this myself too. There seems no option in Rise itself, you can only edit the textstring. I've looked for a workaround, but I've not found this yet. It's a bit frustrating that this can't be established. Changing goodbye.html and zipping again the SCORM folder generates the error as mentioned above. And in LMS (Moodle) there seems no option to find the SCORM package on the server and upload with FTP a changed html file. Hope that Articulate will establish here a solution.

Julia Zetzsche

Hello, Steve,
thank you for your excellent guide.
I also solved it with a static link to my Moodle page. The only thing that doesn't work is that Moodle doesn't get any more data, that the participant has completed something.
When I remove the link from the goodbye message, everything works as before and data is sent to moodle.

Do you have a solution to how I can fix this? Because that's actually a great solution.

Steve Covello

The completion signal should be sent when the trainee clicks on a button in the program to exit. For example, the EXIT button should have two triggers: one for closing the program, the other for sending a completion. The completion trigger should always be "stacked" on top of the exit trigger so that it is sent first. Otherwise, the program will end before the completion is sent.

Second, when you render out to LMS, make sure the completion tracking is set to the completion trigger - not the slides viewed.

All of this would precede seeing the Goodbye message.