How to force Storyline 360 to publish videos at MP4 and not QT?

We have been dealing with a frustration for a few months now and I'm curious if anyone can explain why or tell me how to "fix it".

When we publish to Web / HTML5 only, and leave quality at default or any setting below 9 (the highest quality and biggest files) the video files are being published as <filename>.mp4.qt which leads to frequent playback problems like the video being stuck on the opening frame for many users while the audio cuts in and out. If I bump the quality setting to 9 then I get <filename>.mp4 files as expected and everything plays back as expect but now the media is about 3x the size. 

Before someone tells me it has to convert to QT to keep the size down, I can tell you that if I monitor the file system while publishing, Storyline actually publishes the .mp4 file first and then goes through another very slow conversion step to create the .mp4.qt version of the file and the sizes are almost identical.

If I open the .mp4.qt files locally they play in Quicktime. If I open the project in my web browser (launch story_html5.html) I get the same result my end users are reporting - the video is stuck on the opening frame and the video cuts in and out unpredictably.

The documentation I can find states that all videos are converted to .mp4 when projects are published. Can I turn off the ability to publish in QT and force it to keep all video as MP4?

18 Replies
Crystal Horn

Hi Steve!  Thanks for sharing so much detail about what you're seeing when comparing your published output with different quality settings.  I'm discussing with my team how Storyline handles processing your video files and what we expect to see in the output at those different settings.  I'll keep this post updated.

To make sure I understand the main issue, your end users are seeing poor video playback when you publish at the default settings and host your course on your website.  

  • Is this happening on different browsers and devices? 
  • How do your videos range in file size and duration? 
  • Also, where in your courses do the videos play (e.g. immediately from the beginning, not until a few slides in, throughout the course)?

Thanks for working through it with me!

Steve Klingler

Yes it happens with all browsers we test with (Chrome, Edge, and Firefox).

Videos range in size from <1MB to >200MB but not all get converted to the .mp4.qt format and I can't figure out the pattern. One that consistently gets converted to .mp4.qt when publishing to Web as HTML5 only with Standard Quality (video quality 5) is 62MB  at high quality (video quality 9) and 40MB when published at standard quality (video quality 5). The video on the very next slide is a few MB larger and always publishes correctly as .mp4.... 

The first slide and usually first several slides are static  content intro and navigation. The slides with video follow. 

To confirm - with output format set to HTML5 Only and Quality set to 5, this problem happens if you are publishing to Web but not if you publish to LMS. If you set video quality to 9 then it always publishes correctly but the files are big.  I will send private uploads of an example project file and zip files of the output from Web and LMS.l

 

Crystal Horn

Thanks, Steve!  I'm testing your files now, and I'll send you an email shortly with what I find.  So far, when I open your published output folders, I'm not seeing .qt extensions on your .mp4 files.  My guess is that it has something to do with your default program to open video media, QuickTime.

No worries, though.  We're going to figure out why video playback is not performing well when you host your output online for learners!

Steve Klingler

The really interesting thing here is that the view on the right (HTML5 Only) is actually missing the other video file. Note that the view on the left has another .mp4 two rows above the one you highlighted. That file is missing on the left. I double checked the zip file I sent you, which was produced by Storyline by clicking the Zip option on the publish completion window, and the file is not in there, yet it is still in the output folder. I just manually created a zip file of the folder and the file was included. How does Storyline create the zip file?

Incidentally, if I run the project from the local folder where the .mp4.qt file is present, the video fails to play, so getting it into the zip file does not seem to be the actual solution, but perhaps it is a clue to where the problem is. I will upload the zip file that does included this file via the private upload.

Steve Klingler

Update. It just happened again and this time I was recording the screen with Camtasia with Storyline, Task Manager, and File Explorer all open and in view. Task manager shows that encoder.exe is active when the .mp4.qt file gets created and in the File Explorer window you can see that the .mp4 file is created then .mp4.qt file is created then .mp4 is deleted, leaving behind only the .mp4.qt file. I then compare contents of the \story_content folders and you can see that the .mp4.qt was not included in the zip file.

At that point I stopped recording, but when I open story_html5.html the project gets to the slide containing that video and no video plays. If I rename the file to remove the .qt from the end of the file name I can open the project and play the video as expected.

You can watch it happen here: https://www.youtube.com/watch?v=QCVaqKuLRCY

Crystal Horn

Hi there, Shannon.  Our support engineers had a look and requested that Steve test uninstalling QuickTime from his machine and then republish his file.  I'm not sure if he was able to complete that testing.

If you have QuickTime installed, could you possibly uninstall it and see if that impacts the .qt extension being added to your media files?  You can also work one-on-one with our support team if you'd like.  Thanks!

Traci P

Has there been any update on this?

I'm still having to go through and manually remove the .qt from the file names of most of the videos after I publish. This is a very painful process that I've been going through since March. It doesn't happen on every publish or to every video, and I would love to know what I could be doing differently to prevent this. (I've uninstalled quicktime and I'm still getting this extra extension and the videos won't play in the course.)

Traci P

Not sure if this information is helpful, but these are my updates. 

I worked with support in March or so and discovered that uninstalling Quicktime was a fix. 

The issue came back last week. I reinstalled Quicktime, and I've gotten a few clean publishes on courses that were giving me issues. 

The issue started back on a few courses that I was doing final publishing and clean up on. In both I did some quick video trimming in SL. They were publishing fine before, but after I clipped a video in each, the QT extension started being added to random videos during each publish. I'm not sure if this was the cause, or if it was just something else that made it start back. 

Steve Klingler

Are you using Dropbox, Box, OneDrive, GDrive, or similar file sync software? We determined for us it seemed to always happen on the computers with fast internet connections but not on the computers with slow connections. Our conclusion was that with the fast connection, Dropbox was catching up to and began to sync the .mp4.qt file by the time Encoder finished processing it, which prevented Storyline from renaming it to .mp4. I think Storyline could fix it with some basic error checking to confirm that the rename worked... Lacking that, we just make a point to pause Dropbox or publish to non sync'd folders.

Ashley Terwilliger

Hi Steve,

Thanks for sharing the reminder about working locally, as that is a part of our general recommendations and best practices for working with Storyline files. 

Traci, if you're not connected to another network or shared folder, let us know. Our Support Team would be happy to work with you one on one.