How to let learners go back to previous scenes

Jun 02, 2016

Hi, I just completed a training course in which I built a trigger that will not allow users to move forward until they have completed each slide (via an audio trigger). I have also enabled 'previous' buttons so they can go back to review slides they have already watched. This is working fine. 

However, I am having problems with the scenes listed on the menu. I've noticed that after i have completed each scene, Articulate is restricting those scene and will not allow me to access them.  I have set the Menu options to Navigation Restrictions = Free and it still does not fix this. Can anyone help? Employees should be able to go back and visit scenes they have already completed. Thank you!

13 Replies
Wendy Farmer

Hi Christine

even with Menu Navigation set to 'Restricted' this means the learner can go back in the menu to a scene/slide that has been previously visited so it doesn't sound like that is the issue.

Are you able to upload the .story file - might be easier for someone to offer a solution if they can see and work with your setup.

Ashley Terwilliger-Pollard

Hi Christa,

Thanks for sharing a copy of your file. It looks like you've only listed the scene titles as a part of your menu, and not individual slides? Having that set up won't allow you to use them to navigate, as you can't navigate from the menu directly to a scene. You could include the first slide from every scene as the menu item, and change the title from within the menu to allow it to reflect the scene title. You can read a bit more about working with the menu here. 

Christa Kuchinski

Thank you Ashley! I will make those changes.

Also, on a separate note I can't seem to find a way to remove the extra timing on a few slides (Module 1 slides  2.4,  2.9,  2.13 are a few examples). I have set my trigger to move to next slides when the audio completes, however for these and other slides on my project, after the slide finishes, you can see a white screen after it's done. I've tried to trim the videos but that doesn't seem to help.  Any tips for how I can remove this extra time from the slides?? Thanks again. 

Elizabeth Miles

Hi Christa,

I only looked at slide 2.4, but think the problem is that you have conflicting triggers.  If you change your triggers to look like this screenshot, the slide will advance automatically after the audio completes without the flash of white.  If you're trying to control the learner's progress you can use a trigger to hide the next button until the audio completes, then use another to make it visible.  I really like the look of your course!  Hope this helps.

Elizabeth Miles

Hi Christa,

I think there are two things going on here.  The Slide 2 variable is used on that slide so it doesn't work on subsequent slides, and some of your slide elements aren't set to display to the end of the timeline.  I pulled Module 2 into a separate course and modified slides 4, 7 and 9.  You'll see my notes on these slides, but here's what I did:

  • Slide 4:  removed the "jump to" player trigger and set the audio trigger to jump to the next slide when the media completes.  This moves the slide automatically, so if you choose this option you should click the base layer settings cog to hide the next button because it will never work, even when the audio ends.
  • Slide 7:  this one flashed white, so I selected everything in the timeline, right-clicked and selected "Show until end"
  • Slide 9:  created a new Slide 9 variable and modified the Jump to next slide trigger to use that variable.  I also right clicked on the screencast and selected "Show until end"

You'll know that your slide elements are displaying until the end if you see a right pointing arrow at the end of the timeline. 

This must have taken a tremendous amount of time!  It's very clean and the audio (I assume that's you?) is really clear.  Kudos!


Christa Kuchinski

Thank you so much Elizabeth for reconstructing these slides and for the great tips! I think my naming convention on my variable is a bit misleading (Slide2Complete). I used this variable throughout the entire project.. It should just be named slidecomplete sans the 2. 

I think what will solve the issue is selecting the option you gave me to "show timeline until the end". I didn't realize you could do this. Now I see that the arrows indicate this. I am wondering how you selected all the elements at once on the timeline (slide7) to show until the end. Is there a keyboard shortcut for this...? Or did you manually select each item? Thank you! 

p.s. Thanks for the compliment - and yes that's my voice :)  This is the first course I've made since I just learned how to use articulate within the last month so i'm glad to get good feedback!! 

This discussion is closed. You can start a new discussion or contact Articulate Support.