How to prevent Swf from playing automatically: bug or not?

Hello everyone

I have a problem when using .swf: I set  the option "play from trigger", checked  the options... but the .swf still plays automatically when the slide begins. 

Same problem with the option "when clicked" (I also tried this one)

Is this a bug due to the last update of Storyline?

7 Replies
Ashley Terwilliger

Hi Genia, 

Are you setting this up within the trigger panel or the video properties itself?

To adjust the properties of an embedded SWF file, do the following:

  • Click once on the Flash placeholder to select it.
  • Then click the Options tab on the toolbar.The options that you can modify for interactive SWF (Flash) files are the same as those for videos.  For a detailed explanation of each of these options, see Adjusting Video Properties.
Génia K

Ashley Terwilliger said:

Hi Genia, 

Are you setting this up within the trigger panel or the video properties itself?

To adjust the properties of an embedded SWF file, do the following:

  • Click once on the Flash placeholder to select it.
  • Then click the Options tab on the toolbar.The options that you can modify for interactive SWF (Flash) files are the same as those for videos.  For a detailed explanation of each of these options, see Adjusting Video Properties.


Hi Ashley.

It is exactly what I used (option "play from trigger"), but it still plays automatically... 

Gerry Wasiluk, it is a very simple .swf animation (just a curve animated), I don't find any answer in the best practices you posted.

If someone has a solution to share... I'm becoming desperate.