how to spawn a new browser window with full navigation controls?

This is probably a basic question, but can't quite figure it out.

If I am adding a hyperlink to some text and I want the result of clicking on that link to be open the link in a new browser window and have all navigation controls and an address bar (so students can enter new URLs and navigate), how do I do that?

thanks,

John

14 Replies
Ashley Terwilliger

Hi John,

First, please make sure that you're not testing your course locally - if a web object/URL works here, it may still function incorrectly if it's tested outside of a web server, LMS or CD. Here's more information

If you'd like to share your .story file here or share it with our Support team we're happy to take a look at your course and how the hyperlink is inserted.  

John Souchak

Thanks Ashley. I tested what I was trying on my web server with published output. I tried to have a hyperlink itself spawn a new window with editable address bar and nav controls, and also tried to insert a web object to do something similar. I also went into the player properties to try to edit the browser settings. Nothing has seemed to work so far to produce hyperlinks to display in a browser window with an editable address bar and nav controls. I will upload my .story file here.

John Souchak

I wanted to upload my .story file, Ashley, but when I try to upload it, I get this error:

404 - File or directory not found.

The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.

I get this whether I am uploading the file from a work or home network. Any suggestions? My .story file is 60mb.

John Souchak

I wanted to upload my .story file, Ashley, but when I try to upload it, I get this error:

404 - File or directory not found.

The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.

I get this whether I am uploading the file from a work or home network. Any suggestions? My .story file is 60mb.

Ashley Terwilliger

Hi John,

You mentioned that you've tried uploading it from work or home - is it saved on a network drive or USB? We always suggest to work locally, and that may be why it's unable to find your files if something has happened to the path on the network. Have you tried to upload it anywhere else? The file size shouldn't cause a problem. Could you place the file in a public Dropbox folder and then send us that link? 

Kuriko A

In case anyone else is having this issue, I just thought I'd confirm that this is in fact a bug in Storyline.

Hyperlinks will not work when set up as:

- 'Display in new browser window'
- Browser controls = Default
- Window size = Full screen

Storyline ignores the browser controls setting and makes the window open with no browser controls, preventing the user from scrolling etc. However, it only does this when paired with the 'Full screen' setting. So the result is you need to choose between having browser controls and having full screen. You can't have both.

Miker from Articulate has responded to the bug report:

"We have reviewed your story and we were able to duplicate your issue. I have submitted your case to our Quality Assurance team for their review. You're correct in identifying the current workaround, which is to set the Window size to "Default" instead of using "Full-screen". I cannot offer a time frame for when or if this issue will be resolved so please continue to take advantage of the workaround when inserting a Jump to URL that opens in a new window."

Hopefully we'll have an update on this soon.

Kuriko A

Hi Ashley, 

It has been 9 months now since Miker said he was looking into this software bug in Storyline, and I've not yet heard an update. Can you please follow up on it for me? The Case ID is: #00417376

The issue is basically that Storyline offers an option to select to have a hyperlink open with browser controls (e.g. allowing the user to scroll), but this option is broken when paired with the option to have the hyperlink open in Full screen. See image below. 

Storyline bug - URL browser controls option doesn

I have just tested this again, and it is still not working, even in the latest version of Storyline. Please refer to my story file and output zip folder attached. I'm wondering why this bug has not been addressed even though multiple updates have been released since this issue was reported?

I have just tested this in Storyline 2, and this bug is not present in Storyline 2. So may I ask why the solution hasn't also been applied to Storyline 1? An update would be much appreciated. 

Ashley Terwilliger

HI Kuriko,

Thanks for checking in and sharing your case number. I took a look and do see that Miker shared it was reported to our Quality Assurance team for review, and that the issue is still with them. In regards to why a fix has not occurred, unfortunately that's not something I'm able to answer as we are unable to offer a timeframe in regards to if/when there will be a fix for a particular issue. 

Since the issue is not present in Storyline 2, if you're able ot use that going forward I would recommend that as a work around. 

Kuriko A

Hi Ashley, 

Your workaround of abandoning Storyline 1 and using Storyline 2 instead is unfortunately not an acceptable workaround. I purchased these two programs separately and therefore expect them to both work – not have to abandon one to use the other. Plus, Storyline 2 still has a long list of bugs that are yet to be addressed (some of which were not present in Storyline 1) so whilst it may resolve one issue, it will open up a whole lot more. 

I've heard this line many times before: "we're unable to offer a time frame in regards to when/if the items will be fixed". Based on the fact that I took the time to test this issue, submit a screencast, prove the bug and report it, only to be waiting 9 months and still receive no update, it is not very encouraging for myself and other users that it is worth our time in testing and reporting bugs.

I assumed that the QA team would make it an urgent priority to ensure that the software is bug-free and accessibility-compliant, but based on the 9 month timeframe on this issue with still no resolution, its clear this is not the case.