How to use invalid answer in hot spot quiz question?

I have been able to create conditions to use a customized "invalid answer" in radio buttons (true/false) and check mark (multiple response) quiz questions, but am having trouble doing so with a hot spot question. Can this be done?

 

I have been able to navigate around using the SL360 Modern Player auto generated invalid answer but now cannot get the original correct or incorrect response to display for a hot spot question. Any ideas?

2 Replies
Donna Copeland

Here are two "hot spot" quiz questions I cannot figure out what the conditions would be so that the correct or incorrect layer works nor how to only display the customized invalid answer layer.

I have included what seems to work for a multiple choice and multiple response question. I am getting the right layer as appropriate. Thanks.

Donna

Vincent Scoma

Hi Donna,

Thank you for reaching out and sharing your file! 

After reviewing the file and looking at the corresponding triggers, you are on the right track here! A couple of things to note that I think will help achieve the design you are after: 

  • On the Submit Hotspot trigger, there is a condition to submit the interaction if Picture 1 does not equal normal. I noticed that there weren't any triggers changing the state of Picture 1, so it will always remain normal. 
  • I added a few triggers to change the state of Picture 1, so the Submit button will indicate that a choice has been selected.
  • To show the custom Invalid Answer layer, I removed the condition for the Text Box since there isn't any state changes taking place to cause this to change from Normal.

After making those changes, here is how the slide looks:

I am attaching a revised version of your file that I hope will guide you in the right direction.

Please let us know if you have any questions!