How we solved "Oops! Something went wrong" when previewing or publishing a project

Hi All, 

Thought I'd share this with the community as it's shortened the lifespan of my team by a good few years trying to figure it out, but we cracked it.

We were (on a couple of big projects) getting an error message stating something had gone wrong when previewing or publishing a project.

We couldn't isolate any particular slide as the culprit (each was able to preview individually), so we tried copying the scenes into "fresh" projects. When this didn't work, we then reverted to copying individual slides our slides into a new project. This didn't work. We uninstalled and re-installed, we messed with the player, we even wiped our machines. Nothing helped. 

We then looked at the information logged in the bug report (where it asks if you want to send info to Articulate). The only bit of text I really understood scrolling down the bug report was a mention of a font (ITC Franklin Gothic Med). We then went through the project and changed any trace of this font to something different.

It worked!

I've found quite a few reports where people are having problems with projects not previewing/publishing. It won't cure everyone's problems, but it might cure some.

In short: Check the bug report to see if it mentions a font. If it does, change it!

1 Reply