HTML 5 video player does not go full screen when inserted as a web object video link in storyline 2.


We are having difficulty getting the HTML5 video player to go full screen when we embed the HTML5 video link below into the Storyline 2 course.  Also, we have a working video using a Flash video player.


The video streaming provider advised us that the problem is that Articulate is using non-HTML5 compliant tags, such as "frameset", around the video link which are not recognized by HTML5 and preventing the HTML5 player from going full screen outside of the course window when the full screen icon is pressed.  


20 Replies
Christie Pollick

Hi, Carmen -- Thanks for your question, and may I ask if you happen to be using Vimeo? If so, this is a known issue in with our QA Team currently for further investigation. According to the ticket, "An IFrame within an IFrame breaks full-screen in Vimeo (possibly in other players [YouTube?] as well)." And per the Vimeo site, Vimeo has now stated as follows:

NOTE: If the Vimeo iframe embed code is placed within another iframe, that parent iframe must also include the same fullscreen attributes.

Christie Pollick

Hi, Carmen -- Upon further investigation, yes, this issue using Kaltura has already been reported to our QA team. I will go ahead and add this thread to the ticket, and while I am not able to provide a workaround or timeframe in which this may be addressed, I will be sure to provide and updates or information I receive here in the thread. 

John Harman

Christine- We are experiencing that same exact issue on a recent batch of courses.

Courses are exported as html5, video is fed from Kaltura into a webobject in the course and does not go to fullscreen when clicked. Tested the iframe code externally and if we include the allowfullscreen option it works, but the webobject options in Storyline don't allow for that.

Any update in the last 4 months?

Patrick Geiger

For those looking for a solution in the future ... I did happen to find one. The issue is that the iframe dynamically created in the HTML5 output doesn't have the allowfullscreen attribute set. I "fixed" this by editing the html5\lib\scripts\app.min.js file (see highlighted portion in attached image). Note: This was done with Storyline 360 output.

Implement at your own risk!